Solution: Handbrake encoded mkv's freezing / not playing

Hey guys.

Well, although I have been a HUB user for, well, just about the day they came out, I decided to go out and get me a SMP for one of my other rooms because even though the HUB and SMP’s have their faults they are still some of the best players out there. 

Or so I thought until I plugged it in and tried to play some of recent mkv / BD encodes (Handbrake 0.9.6) and either they wouldn’t play or they would seem to just freeze/stop in random places.  Which in-turn would cause me to have to reboot the SMP and send my blood pressure sky high.:angry:  One reason it was beginning to get under my skin is because I knew that there wasn’t anything wrong with the encodes, because the same files would play flawlessly on my HUB and my old Gen1 Live player.  So I knew that it wasn’t anything to do with the file.

So, anyway, to make a long story short (I know too late), after looking at each and every file that wouldn’t play and comparing those to the ones that would, I think I finally found what’s wrong.  The problem seems to be that the SMP  can’t handle the newer “libmkv 0.6.5” writing library which is used by Handbrake 0.9.6 and Nightlies (which is why mkv’s encoded with Handbrake 0.9.5 work with “libmkv”).

So what’s the solution, going back to Handbrake 0.9.5?  NO.  For one thing, if you didn’t know this, the Handbrake nightlies now allow for PGS subs to be burned in and so if you are needing that for certain movies then there is no turning back.  The easiest, and fastest solution is to run your Handbrake mkv’s through MKVmerge (MKVtoolnix) which uses “libebml v1.2.3 + libmatroska v1.3.0” writing library and the SMP seems to have no issues playing.

Basically, since MKVmerge is a 1:1 encoder (not a transencoder like Handbrake) all you’re doing is changing the writing library, although you may also see a small change in bit rate, but that want matter much since that doesn’t effect quailty at all.  And MKVmerge only takes a few minutes (depending on your file size) to encode unlike the hours it will take you to re-encode with Handbrake.

Anyway, I hope that helps some of you that have been having problems.


Thanks for sharing this workaround.

The MKVToolnix/mmg workaround has been recognized before. I think it is valuable that you identify the “libmkv 0.6.5” writing library as the issue. I think WD should condider a firmware upgrade which takes this into account.

Yes, I know that the MKVtoolnix workaround has been suggested by others members before.  However, my whole reason for posting this was to pinpoint the issue as being that the SMP can’t read the “libmkv 0.6.5” writing library.

And because, there have also been other suggestions to attempt to fix this issue such as go back to HB 0.9.5 or rollback the FW, which is not necessary and at least going back to HB 0.9.5 isn’t an option if you want the newer functions provided by the HB Nightlies (which use the same writing library) like being able to burn-in PGS subtitles.

Ok, I have the same problem.

I used ts files from my humax 5050c. I used handbrake 0.9.6, The files will not play, or play for a while and then the wd tv live hub freezes.

I have tried the mkvmerge work-around. But still the files will not play? It now says that the file is a not recognisable format?

DVD’s I converted with handbrake 0.9.6 are not a problem?