MKV's Encoded with Handbrake 0.9.6 problems continue

Owner of a WDTV Generation 1 and never had any problems playing any of my files.

Purchased a WDTV Live Streaming (SMP) and had nothing but problems with it from Day One.

From the off, always noticed it was slow. As slow as the Gen 1, in many cases even slower.

But the main issue:

According to firmware 1.10.13 - the issue of playing files encoded with Handbrake 0.9.6 has supposedly been fixed.

For me however, it has not. I have lots of videos encoded using 0.9.6 and when trying to play any of them sometimes these will play for a bit, but eventually **bleep** out  - so cannot successfully view any of these MKV’s to completion.

Just to mention, this is all via the USB port - I have tried the port on the side and the port on the front - makes no difference. I have tried Western Digital drives (500gb, 1TB, 2TB) and the same for Hitachi drives - but again, no difference.

I am now on firmware 1.15.10 and the issue remains the same.

I know about the MKVMerge method - for some videos this worked, for others it did not.

So I would like to confirm, the issue is not yet fixed.

Hello, try downloading the latest firmware (1.16.13).        

Updated to 1.16.13 as mentioned

The problem is still exactly the same, nothing has changed several firmware revisions after it was supposed to have been fixed.

I have dozens of MKVs created with 0.9.6. They’re all working fine…

How about the current Handbrake ?

After testing it for around a day I thought I was actually having some success, but no, it is no different to the earlier releases. The problem is exactly the same as before it was ever claimed fixed.

I did a factory reset, then installed the latest firmware.

The behavior is like the previous firmwares - those encoded in Handbrake 0.9.6 will work for a while, but eventually give up and all you are left with is the spinning circle - leaving you with no choice but to reboot.

As for Handbrake 0.9.9 I don’t know personally (as all the files I am working with and testing were encoded in 0.9.6).

The last few encodes I have done were using SVN 5415 which was built in April 2013.