Problems after any firmware upgrade

My WD TV Streaming came with an old V1.01.43. I had a issue of the movie stopping occassionally so upgraded the firmware. Now I’ve tried virtually every firmware version listed on the WD site (specifically for the streaming media player) following the instructions. I’ve done it before with the Gen 1 TV Live. I’m using a 500GB WD Elements portable.

Problem: I can’t load MKV movies that my Gen 1 can. The spining yellow circle just spins away!  This is the second unit to do the same thing.

I’ve tried the hard reset and still no go. 

Any suggestions would be appreciated before I return it for a refund.

I am using the latest firmaware version V1.07.18

My copy of “Real Steel” hangs at 36min 36 sec. Looks a little to me like Cinavia protection has been incorporated.

No. There is no Cinavia protection. There could, however, be an error in your MKV file. Maybe it’s just that the Gen 1 managed to ignore it somehow. If it’s not an encoding error, you may be able to fix it by running your MKV through mkvmerge.

1 Like

Thanks for that.

I’ve encoded all of my blu rays using Handbrake with MKV container and H.264 video Dolby or DTS passthru.

They work perfectly on the Gen 1 and VLC. I’ll try your suggestion using mkvmerge.

I know this is a WD forum but is anyone prepared to comment on the Phillips media units?

Thanks Strider_Nemasis. I ran the MKV through Mkvmerge and the movie ran through the halt point so your theory looks to be correct. How annoying that Handbrake produces errored mkvs. I’ve probably got a lot of them to fix.

Kudos to you.

You’re welcome. But maybe the MKVs created by Handbrake are according to the specification, but the WD TV has a compatibility issue with them (or the settings you’re using for the container). Guess we can’t be sure that Handbrake is at fault here.

EDIT: Looks like there are other people having problems with Handbrake MKV’s freezing on the SMP, especifically with version 0.9.6.

The MKVs where generated using the recent Handbrake 0.9.6 release. Furthermore the 64 bit version.

I just add this for others who come upon this thread.

But you are correct: Is it Handbrake or WD not adhering to the Spec.

A Further update. The video freeze issue appears to be resolved running the 0.9.6 Handbrake through Mkvmerge but there is another issue which still happens occassionally. The movie when playing will flip back to the previous menu screen but with the audio still play. Pressing Resume will get the video back.

I don’t know if it is the firmware or the sigma chip which unpacks the MKV container. However, it’s fair to say there is a compatability issue between Handbrake 0.9.6 and the WD Live Streaming. Unfortunately I’ll be staying with Handbrake 0.9.5.

I have exactly your issue with Handbrake 0.9.6, I got this problem in 2 movies, I tried to play them many times but every time they stuck at same point. If you watch them with a PC everything is played fine.

If you pass the file obtained from handbrake in mkvmerge the movie seems to run well.

I don’t use strange options in Handbrake, just ATV2 profile, mkv container, audio AAC faac (bitrate 160), subtitles vobsub with option “burned In” enabled and that’s all.

What do you think guys, it’s better to come back to the past versione 0.9.5 or “clean” the movies with mkvmerge?


Instead of going “backward” to 0.9.5 which is aeons old, I would go Forward to a “Nightly” build.

But wouldn’t a “nightly” just be a current 0.9.6 tweak with no fix to the WD live SMP? There is no problem with my WD TV Live and the problem seems to be specific to the SMP. The issue does not seem to get any mention on the Handbrake forum. I also don’t know if it is on the WD fix it agenda.

Given the amount of time to encode even with a fast PC I’m sticking with Handbrake 0.9.5 until the issue gets a higher profile.

I have the same situation with MKV files.  I tried all kind of differnet encoding combinations in Handbrake 0.9.6 but I still couldn’t create an MKV that would play all the way through on the WD-SMP without freezing up.

I dropped back to Handbrake 0.9.5 and all is well again.

I don’t know whether it is Handbrake or WD that is causing the incompatability, but at least 0.9.5 works.

Also the latest Nightly Build is “affected”. Same issue.

If you search in the handbrake forum you will find a topic on this “issue” (I found it yesterday).

The “solution” for me is to do a final pass with mkvmerge because it solves it, for my point of view this issue could be correlated to the header compression. I don’t see any other thing that could be because the issue go away with just this “trick” (mkvmerge).

As I said earlier the tip another member gave about mkvmerge seems to solve the “freezing” issue. However, on some movies I  find a less common glitch. A movie sound track will keep playing but the video will flip back to the movie start menu. “Resume” will bring the video back in.This will happen even if the MKV has been passed through mkvmerge.

I only experience these two problems with Handbrake 0.9.6.

Sincerely I don’t fully understand, help me to understand, what do you mean with “movie start menu” ? From my acknowledge the mkv format doesn’t permit a menu.

Maybe you wanted to say that the WDTV SMP stops the reproduction and brings you to the folder where the mkv file is contained?

In addition, could you please tell me the movies where you got this glitch, I would like to investigate on this. 

EDIT:  Did you have disable the header compression in mkvmerge?



You say

“Maybe you wanted to say that the WDTV SMP stops the reproduction and brings you to the folder where the mkv file is contained?”

I thought that was basically what I said except the audio keeps playing.

I cannot recall the movie.

However, you raise an interesting issue regarding header compression. I have found out that after mkvToolnix V4.2.0

header compression is on by default and you need to manually set it to off. The space savings with header compression appear to be minimal anyway.  I would have thought header compression "off "was a more sensible default - anyway that’s the way it is.

It may be that WD TV Live SMP does not properly support header compression. This may explain the second error we are talking about.

Header compression has been fixed several firmwares ago, I still turn it off though.

I’m guessing quite a few WD TV Live SMP users are using Handbrake.

Is their any update on the Handbrake V0.9.6 incompatability issue?