AAAARRRGGGHHH! new firmware!

I’m sure this has been discussed to death already but I’m getting so [deleted] p****d off with the latest firmware on the WDTV Live I’m going to smash it through the [deleted] wall!!

It will play next to nothing that it used. MKV files that previously worked fine no longer play. Running them through MVK Merge doesn’t help either!!

Same problem with AVI, MPEG, MP4 and just about every other file type I have. I appreciate that it is the codec within the ocntainer but why stop supporting previously fine codecs?

Fix it and fix it now WD

Dave, just in case you hadn’t heard or read it, you can UNDO the firmware upgrade and be happy again.  ;)

Check here:!!&p_li=&p_topview=1

Rollback the firmware. Full instructions etc here.

I guess I can somehow feel your pain.  I actually picked up one last night and once I got it on the network I had to do 2 firmware updates (one was  1.03 and the other was 1.04) and once that was done I was up and running and so far no problems.  Now I could be the odd ball since I went from never using it, updating immediately and then started using it with a fresh device. I did get it working with MP3, FLAC, AVI, VOB and MKV.  When I get home tonight I will what else I can play (I may have an MP4 and MOV floating around).  Sorry to say so far mine is working and I have many fingers crossed at the moment.

1 Like

Great minds think alike.  :)

I knew I could do this, but my post was more about the frustration of HAVING to do it.

The previous versions worked almost perfectly for what I bought my WDTV Live to do, and I wrongly assumed the new versions would bring new functionality often talked aobut here but without taking away what I already had.

Its a poor show from WD to force me to downgrade my box because it won’t now play previosuly perfect files

And we are sorry about that, Dave.  We are, however, working on fixing as much as we can of what got broke.  I can’t promise when, where, or what, but I know we’re working on it.


Bought my unit 1 year ago and have continually had problems of one sort or another.  Most of the time it is very temprimental and refuses to work until it is rebooted - very annoying.  The last one was the issue with certain MKV files that were not compatible and screwed it up so that it would paly nothing untill rebooted.  This problem seems to have been fixed during the latest firmware update but now it will not play Video TS files ((VOB).  What the [edited] is wrong with this machine.  I too have been very close to throughing it out of the window on more than one occasion.  I have now got to the end of my tether.  Can anybody out there recommend something I can buy that works - I will treat myself to one for Xmas.  Thanks - all suggestions welcome.

I reverted the fw back to 1.02 because of broken hdmi digital sound. What’s really annoying is that I never know if a newer fw is available so I have to visit this place to check if something newer than 1.04 exists.

hey guys,

cooooooool down :slight_smile: got the same problem after i haven’t connected my wdlivetv over 4 months to the internet. i have done 2 fw updates and none of the files seemed to work. i was about to crash it like kingdave did. after some research on the internet, i found out that if you pull out the power cable from the box and wait about 5 seconds or 10 and plug it in again, the system does a full reboot and voila: everything worked fine again. well except my stereo av out. it doesn’t do since now, only got a noisy buzz sound through my speakers and THAT **bleep**!

well, hope i could help you guys.