Tried to connect a USB hub. Now the port doesn't work

Greetings all, season or otherwise.

I find myself in a bit of fix here as I’m trying to link together my My Cloud to a set of USB 3.0 SeaGate external HDDs and I’ve hit an impass.  I’ve read online about this and it should work fine as long as you’re linking them through a USB 3.0 hub with it’s own external power.  And it did work, but was kind of unstable.  Well all of a sudden it’s stopped working at all together.  And even worse now I can’t get ANY USB devices to link into my My Cloud.  Not the drives indivitually, not a 2.5" USB HDD drive in an enclosure, nor even a standard USB thumb drive.  Doesn’t even show up in the UI when I connect something into it.

I’ve tried doing my best reading forums and posts anywhere I can find them.  I’ve run many self tests and checks to little affect.  I’ve even go so far as to do a ‘System Only’ factory reset on the device.   Yet no dice…

Anyone have anything suggestions?


Have you tried a power cycle?

Also, what firmware version do you have ?

Yes.  First thing I tried was a power cycle when I first noticed the issue.  And software version is v04.01.02-417.

Well for whatever the reason the device is working one again.  So never mind…

Defeintly won’t be buying any more Western Digital devices if they just start to randomly act up like this…