TMDB returns nothing - frustrated!

All I expect out of the HUB is for it to work properly.  I have been fighting with the meta-source manager and it just plain doesnt want to return antyhing.  Seen all the sites, fourms and support - to no avail.  I’m not going through the headache of using thumgen or other software to do what I paid for when I purchased this unit. 

All updates are fine and the unit is hardwired to my router.  Filled out a support tickect and all they said was to check the names of the files.  This doesnt quite cut it.  Not gonna do it - not with more than a 1000 flicks to rename.

I tried the new XBMC/KODI media center - connected two WD external HDD’s to my laptop - ran the scraper in KODI and BAMM - all 1200 +/- movies had thum’s, detail, fanart, profiles everything.  I needed to change a few - but no hassle at all.

Why cant this happen with my HUB.  I go as far back as the original WDTV.  And am disappointed with Western Digital right now.  It may be time to just remove the HDD from the unit and toss the rest.

Unless any of you folks have any sure fire ways to make it work properly.

Thanks in advance.


you do realize the WDTV Live Hub is a Dis-conntinued device, don’t you ?

last firmware update was about 1 and Half Years ago

Not surprising KODI worked fine … because it’s updated regularly

I understand it’s an old piece of equipement, but thought it may be usable.  I bought it a couple of years ago and let it sit due to the glitchy-ness of the unit.  I broke it out a few weeks ago and from seeing the posts in the fourms and support pages - I though it may have been updated or fixed by WD. 

Oh well - I can use the HDD from the unit and toss the rest.

Thanks folks. 

Could be you, for I have just used Get info on

and it worked.

Yeah - it’s probably me.  If I could change the meta-source I would.  Do you know how? I tried to change the site but to no avail.  Not sure what you mean - do you manually change the site?

Any help is appreciated.

TMDB stands for

Yep - looks like that’s the scraper shown under setup/meta-source manager.  I tried to change the site the unit goes to for info - but can’t change it.  When I choose ADD New meta-source, my only options are internal drives or external drive - no access to a site or even the network.

If your intention was to have me direct the unit to that particular site - please tell me how?


I am just saying that it works, no one so far had changed meta source. So, again, consider using either software like

WDTVHubGen for vast amount of movies or do change names of the files manually.

Thanks - I’m done with it.

Yup…yank the drive in the Hub and buy a Zotac Zbox BI320W put it in that and share it. Then install Kodi V15.0 Alpha! Done.

There ya go.  Use a mini-pc and eliminate the WDTV altogether.  Smart.