TimeMachine Backups stop work after update to macOS 10.12.2

Configuration: iMac macOS 10.12.2 (16C67), WD My Cloud 2TB 1-bay FW: 04.04.05-101

On macOS 10.12.0/1 TimeMachine backups works fine but after update TimeMachine backup always fail.
1 Share for TimeMachine has issue, connect to other Shares via smb:// is correct.

1st attempt – reset TM backup
So I’ve try stop TM backup server in web interface on My Cloud, delete Share reserved for TimeMachine, remove backup disk in macOS System Preferences -> TimeMachine. And try to setup new TimeMachine backup disk, but it fail too.

2nd attempt – direct connection using Finder’s feature "Connect to server…"
So I’ve tried to connect to TimeMachine share using system/macOSfeature “Connect to server…” enter afp://wdmycloud.local, enter password, select TimeMachine backup share –> but is fail again wit console message: “ERROR: AFP_Mount - theEnumerator->Mount failed 2”. So I’ve tried smb://… protocol too but fail with console message “smb_mount: mount failed to wdmycloud.local/TMBack, syserr = Unknown error: -1073741275”

My questions are:

  1. Has anyone similar issue after update macOS Sierra to version 10.12.2?
  2. Is there any other method for reenable TimeMachine backups again.

Thank you

Hi,

I recommend you contact WD support for assistance with this. You can also wait to see if another user with experience can share some ideas regarding this topic.

Fortunatelly I found solution. Problem was in macOS not in MyCloud device.
Problem solved:

  1. Remove saved passwords in Keychain.app
  2. Launch Onyx.app & clean caches (Automation tasks).