Thumbnails on images load and then dissapear D:

Hello there, I am a new and very satisfied owner of an EX2. I’ve never owned a NAS or anything like one of these enclosures before and I am quickly realizing how amazing these devices are and how much they are capable of.

Unfortunately I am having a bit of a frustrating issue that has been going on for a couple weeks that I have been trying hard to resolve but haven’t had any luck. To summarize as best I can, I am experiencing a problem where the thumbnails for my image files aren’t displaying properly when viewed in windows explorer. To be more specific, when open a folder and the contents are displayed, I will see the thumbnails show correctly for just a fraction of a second, and then they disappear and are replaced with the placeholder image that we see in windows when an icon is loading or thumbnails are disabled. I hope that makes sense when I describe it this way.

To give more information, this problem only happens within Explorer when I view files on the NAS itself, when I view images locally on my computer, there is no issue. In fact, if I copy those same images to my computer and then view them, they display fine. Further, I am having this issue across two different computers - my desktop as well as my mini ITX computer under the TV (HTPC). Both of these computers are using Windows 7 if it makes a difference. I have viewed the files on my Android phone using a file explorer app and the files display correctly there too. Images in the WD file manager app also show thumbnails correctly, and I just attached an external hard drive to the enclosure to see if I could thumbnails on it as well, and I do, so I have no idea what’s going on.

Has anyone had anything like this happen to them? I would assume its user error or something on my part within Windows, but since its happening on two different computers I’m a little confused. It wasn’t an issue when I first got my enclosure, then it became an intermittent problem, now I can’t view thumbnails at all. For me it isn’t life ending - I’m still overall really happy with the storage. But it’s beginning to bug me more and more. I would really appreciate any input if anyone has any, thanks a lot for your time.

Edit: I’m adding an edit here with what I believe solved my issue. “The file that I deleted was called ‘IconCache.db’ that was located in my %localappdata% folder (C:\Users\MyUser\AppData\Local). I also used disk cleanup again and deleted ‘thumbnails’ once more just to be sure.” It seems that there are a lot of possible causes for this problem, but this appears to be the solution that helped me out. Good luck to anyone else who might run accross this problem.

Sounds like a Windows 7 problem to me. Can you see if the first solution offered (the one with 8 votes) resolves your issue? ->  http://superuser.com/questions/71652/windows-7-image-thumbnails-fail-to-appear

If it resolves your issue, please click on the star below my username on the left to give me a kudo and mark this post as solution.

Hello Cybernut, thanks a lot for replying, I really appreciate it. Unfortunately I tried all of the solutions on that page and it doesn’t look like I’m getting any results. I’m trying to remember all of the things that I’ve tried, I’ll try to keep a list for future reference.

  • I have gone into folder options and made sure ‘Always show icons, never thumbnails’ is unchecked. I have also checked it, applied, and then unchecked just to be sure.
  • I have deleted all of the thumbnail .db files that were in ‘C:\Users\user\AppData\Local\Microsoft\Windows\Explorer’ in hopes that it was a corruption issue and killing them would generate new ones.
  • I have gone into disk cleanup and had it delete everything under ‘thumbnails’ - I’m pretty sure this was the same as deleting the database files, but I did it anyway to be sure.
  • I read somewhere that having MS Publisher could cause issues like these, I do have Office installed, and I did remove Publisher, after rebooting the system did some kind of update and clean up before I could log in. I actually thought this worked at first and I saw a lot of working thumbnails, but later I found that they weren’t working again.
  • I have checked for custom icon handlers, if I understand what I saw when checking, I don’t have one.
  • I just deleted another thumbnail db file that was in another location, I have to reboot to see if it worked, but I’m going to assume that it’s not going to do anything. I’ll reply if it does of course.

An interesting thing that I have noticed is that if I select an image and refresh the page while still having that image highlighted, that thumbnail shows correctly once the refresh is complete. I dunno, I don’t get it. In any case, I appreciate the help. I’ve been at this off and on for a couple days now, I think I may just have to get over it and deal with not having the thumbnails on the NAS.

Hey here’s some good news. I haven’t even rebooted yet from deleting that other database file but it looks like it is working. The file that I deleted was called ‘IconCache.db’ that was located in my %localappdata% folder (C:\Users\MyUser\AppData\Local). I also used disk cleanup again and deleted ‘thumbnails’ once more just to be sure. I’m not sure if using disk cleanup again was necessary for my fix, but things appear to be working normally for the time being.

I haven’t hopped on to my HTPC to do the same to see if it fixes it there as well, but I will in a while. I’ll write back if it doesn’t or the problem comes back. I’m confused that this happened on two separate machines, I wish I knew more about what caused the problem, but I’m just happy that its normal again. Special thanks to the community!

Glad you found a solution by your own efforts…that’s the best feeling :slight_smile:

I wish some of your luck rubbed off on me…been trying to resolve a computer issue myself (not EX2 related) but have had no luck despite trying countless things for over two-three days. Gets so frustrating. And in my case, it’s not a small thing like missing icons that I can ignore…it’s inability to connect to a database…so starting to feel like I’m chasing a lost cause :frowning: