"There is no media in the current folder" Error


#1

I know this issue discussed many times under different topics. I have a different version of the error. Here it is.

I established the connection between WDTV Live and my router via a wireless usb adapter. There are no problems accessing YouTube videos, browsing music etc. There are also no problems accessing the “local internal drive” of my PC (Partitioned C and D drives).  Simply shared my D drive with the “read” permission only to “Everyone” and voila every single media file in my D drive appeared on WDTV Live.

Other than the internal drive of my PC I have 2 x 1 TB External USB drives connected to the USB ports of my PC. I tried every single advice on the web but I could not manage establishing the access to the share USB drives connected to my PC. I tried even formatting one of them with FAT32 without success.

Does not matter what change I made I can still access to the files on the internal D drive but not to the USB drives. Do you have any idea that can help me to overcome this issue?

Thanks in advance.

Levent


#2

Where exactly does the ‘There is no media in the current folder’ error come into this?

From the description of your problem it appears that you are simply unable to see the external USB drives attached to your computer. Do you actually get the above error?

Obviously I assume that you have made tham shared on your computer.


#3

Through the video menu I choose network shares and then select the name of the computer being shared then asked for the user name and password. After that the login to the share completed with success but the error message (there is no media…) appears

Yes I can not see the external USB drives attached to my computer. It does not look like an authentication problem. Because at the same time, I able to see my computers shared internal drive  but I can not see the shared USB drive connected at the same computer.


#4

Are you able to see the shared USB drive when browsing the network using another computer (e.g. a laptop)?


#5

Sorry guys, I was not with the computer all the time and could not response properly. Right now I’m trying the connection through a notebook. I will let you know.


#6

The notebook is able to list the shared drives and access to the files in the internal drive but not to the external USB drive. I guess this not a WDTV problem it is about permissions but I also tried a lot regarding the permissions. Is there anything you can recommend?


#7

Levent wrote:

Through the video menu I choose network shares and then select the name of the computer being shared then asked for the user name and password. After that the login to the share completed with success but the error message (there is no media…) appears

 

Yes I can not see the external USB drives attached to my computer. It does not look like an authentication problem. Because at the same time, I able to see my computers shared internal drive  but I can not see the shared USB drive connected at the same computer.

Normally after you click on network shares it will show you your computer name, you click on that - sign in - and then you will see all the shared drives on that computer. You say that you can see your computer hard drive but not your USB drives, so what are you clicking on that gives you the error message?


#8

Yep, sounds like a network share permissions issue.

First thing to do is make sure you have shared the external USB drive!  I know that on my system, unplugging the external drive wipes out the share and it needs to be re-created when plugged back in.

For Vista, that’s done as follows:

General Network Settings

Just some things to check / try.  Here are my settings within Control Panel > Network and Sharing Center:

Network discovery:  ON  (Workgroup is called:  WORKGROUP)

File sharing: ON

Public folder sharing: ON  (Select - …anyone can with network access can open, change and create files)

Printer sharing:  ON

Password protected sharing: OFF  (my Wi-Fi is secure, so why create hurdles?)

Media sharing: OFF  (we’re using Network shares, not Media Server)

At this point, I’d turn your WD TV Live OFF.

Sharing your External USB Drive  

  1.  Plug in external drive and wait for it to be recognised by system.

  2.  Right click external drive icon in Explorer.  Click  Share…

  3.  Press the Advanced Sharing button.

  4.  Tick the Share this folder box.  Type a meaningful Share name but keep it short (e.g. EXTUSB1).

  5.  Press the Permissions button.

  6.  By default, it should give “Everyone” Read-only access.  This is sufficient for now.  Click OK.

  7.  Press Apply then OK.

  8.  Click Close.  Done!

Start up the WD TV Live.  Go to Video > Network Shares > [ComputerName] and see if the External USB Drive is now listed.


#9

PixelPower thank you. I guess I already tried pretty much what you have told. It is clear that this is not a WDTV issue otherwise I wouldn’t be able to see the other drives of my PC.  I will try some other settings changes regarding the share and permission and let you know what. Thank you all for your help.


#10

I found the solution to that problem. When I checked the “Event Viewer” in the administrative tools I saw an error that the “irpstacksize” is too small. There is a registry key you can play with this value by adding a DWORD value if it is not existing there already. The key is:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters

and the value I used to fix the problem is 18 in Decimal base. After that I restarted my computer and all the shared drives including the external USBs are on WDTV Live. Hope this helps to others too.


#11

Interesting…  could you mark your last post as the solution, so that others will be aware of it?  :)


#12

I have been struggling with the same issue for 2 weeks   I was unable to share external USB drives.  Made this simple registry entry and it was an awesome relieve to have it work!  Thank you Levent! You’ve been a great help!

The setting was completly missing from my Windows XP.

Note:

* type IRPStackSize exactly as displayed (case sensitive)
* change base to Decimal
* close the registry and reboot.