System & Services Unavailable - Data Still Intact


#1

  Before I start - detail on the device: MyBook World Edition 2 - 4TB - White Light

  My MyBook W II device has been working and running pretty much perfectly for almost a year now. I’ve been happy, even if data transfers are a little slow.
  Then today suddenly out of the blue I’ve hit a serious snag that even my extended Unix / Linux background is having trouble resolving - the system being built around an imbedded Linux distribution / version that I am unfamiliar with…

SEQUENCE OF EVENTS FOLLOWS::

  Everything appeared to be working OK - I was in the middle of a large (27GB) file transfer from another MyBook W II device which was proceeding normally - but when accessing the Disk Manager page in the Network Storage Manager web frontend I was confronted with an empty page - the usual information on the two installed disks did not show up in any way!!!
  Everything else seemed to check out OK. In the Volumes & RAID Management page all my settings and what-not showed up normal and OK as usual.
  So in the hopes of restoring the normal Disk Manager view - to hopefully ensure that the disks were OK and so-on - I halted my transfer and reboot the device.

  Upon restarting I am now completely unable to login to the Network Storage Manager webpage! When trying to access the page through my normal bookmark / favourite I get the following error:
"XML error: no wixnas object found! "

  Using the WD Discovery tool also shows unusual symptoms - my other two WD NAS Devices show up and are manipulable as usual, but while this problem device shows up in the listing (“Network Drives Found”), when clicking on it to try manipulate it in any way, the right hand pane (“Things To Do”) never refreshes or allows any manipulation of this specific device!

  Hoping to resolve things quickly I accessed the device via SSH.
  When logging in and comparing my two identical devices::
  My working MyBook W II device shows this:
/ # df -h
Filesystem Size Used Available Use% Mounted on
/dev/md0 1.8G 520.9M 1.2G 29% /
/dev/md3 949.6M 19.2M 882.2M 2% /var
/dev/md2 1.8T 1.3T 489.8G 74% /DataVolume
/dev/ram0 61.9M 20.0k 61.9M 0% /mnt/ram
/dev/md2 1.8T 1.3T 489.8G 74% /shares/Public
/dev/md2 1.8T 1.3T 489.8G 74% /shares/Download
/dev/md2 1.8T 1.3T 489.8G 74% /shares/craigdjm
/dev/md2 1.8T 1.3T 489.8G 74% /shares/Menageryl
/dev/md2 1.8T 1.3T 489.8G 74% /shares/Private

  The problem device shows this:
/ # df -h
Filesystem Size Used Available Use% Mounted on
/dev/md0 1.8G 1.8G 0 100% /
/dev/md3 949.6M 17.5M 883.8M 2% /var
/dev/md2 1.8T 1.4T 405.3G 78% /DataVolume
/dev/ram0 61.9M 20.0k 61.9M 0% /mnt/ram

  I have since discovered the twonky media server had a log file filling up the root. I have cleaned this up now, recreating the file in an empty state. The problematic system now shows the following:

~ # df -h
Filesystem Size Used Available Use% Mounted on
/dev/md0 1.8G 94.6M 1.7G 5% /
/dev/md3 949.6M 17.5M 883.8M 2% /var
/dev/md2 1.8T 1.4T 405.3G 78% /DataVolume
/dev/ram0 61.9M 8.0k 61.9M 0% /mnt/ram

  The only hanges I’ve detected since opening up more space on the root is that the WD Discovery tool now responds and refreshes when I select the dodgy device. It’s still of no use however as no shares are ever listed to browse or map, and attempting to configure the device from the utility just brings up the same error message as mentioned earlier in the browser.

  I have checked by browsing the device using SSH - all my data is still intact. But I am obviously completely unable to access it in any other way.
  I don’t have redundant copies of the 1.6TB of data on this device - the fact that this is a RAID 1 device WAS the intended protection right there!!!
  As such I cannot afford to factory-reset or similar the device. I need to keep the data intact.
  But I need to restore normal usage and manipulation of the device badly!!!

  ANYBODY THAT CAN SUCCESSFULLY HELP ME ON THIS ONE WILL BE PERMANENTLY PLACED IN MY HOME HALL O’ FAME AND HEROES!!!

  Thanks in (hopeful) advance!

  ~Menageryl.

  -Jack of All Trades, Master of Some!-


WD myBook World edition 1To : XML error: no wixnas object found!
MyBookWorld 1TB Not on network/discovery/ip
#2

I would in that situation verify that:  /usr/private/user_smb_conf/.overall_share lists the shares as they should be, and if so, try: 

/etc/init.d/S90smbd stop

/etc/init.d/S90smbd start


#3

’  Thanks for the attempt at help mate - I appreciate it hugely!

’  As it is, I managed to figure out and resolve the problem myself after about a day worth of fiddling and panic!!! I thought I might just put the information down here in case anyone else ever hits similar issues they need to reference…

’  Turns out there was one step I left out in the process I followed in an attempt to get the system back into normal operation… At one point I actually tried to restore the system’s configuration using the most recent backup I’d made to another location - using the web frontend.

’  What I eventually discovered is that when the Twonky media server had filled up the system’s root partition with a humungeous log file, my attempt to restore the configuration corrupted the base-config file that the whole system references at boot-up to properly build services etc. Basically, when trying to restore the config, the system tried to write back to that file without checking to verify if there was enough space to do it and without confirming that there was a problem.

’  Once I tracked that issue down all it took was the deletion of the massive log file that was taking up space, and then a manual (read: by-hand) rebuild of that config file - something I could fortunately do pretty easily knowing my device configuration pretty well and having a second, identical device available to reference for syntax and file-layout.

’  Once I did that and reboot the system, viola! Probem solved!!!

’  I hope my (fortunately relatively short period of) pain and anguish helps other down the line!