XML Error: no wixnas object found! (no access at all)


#1

Hi

Primary use: Streaming

after purchasing the WD 4 tb Sharespace i loaded all my data on to it

and 2 months later when i tried to log in i get the error.

XML Error: no wixnas object found

the WD discovery software fails to detect the drive

there is no web interface access

there is no network access

however it still streams

I have tried using ubuntu live cd to read the partition with no luck(i can see the partitions)

I have tried calling WD support and i was told to return the device but what about my data

i read something about doing a sector by sector backup, Could this work

i would really appreciate some help on this matter


#2

I bought this from Harvey Norman Gardencity who have been excellent in trying to help

they have also pulled this product from there shelves and will no longer stock it until the issues are fixed


#3

Have you tried accessing the device directly by it’s IP address?


#4

yes with no luck


#5

There’s no web interface at all?  What error do you get when you try to access it?


#6

I just had the same thing happen to me.  My question was how can i recover the files before i send it back.   I was using Raid 5, and I am going to be pissed if they can’t tell me how to do it.  Which I have a feeling is what they are going to tell me on Monday.


#7

after speaking to WD initially they informed that i should get a 2nd drive from where i buoght it

however after trying to sort this out WD have said to HN that they will not provide a drive for this very unlikely fix


when trying to access via ip i can see the printer

when trying to access via webpage i get the

“XML Error: no wixnas object found!”

i think this is going to start popping up for a lot of people and WD are just ignoring it completely

check the world book forums for plenty of posts regarding this issue


#8

I found another community regarding this problem and it had post  after post about WD lack of tech support and this problem arises from not have a firmware update done.  I did find a place that detailed the problem and the solution was to use linux os to clear out the directory that is causing the problem.  Basically it is TWONKIE or Honky or whatever is creating temp files and accumulating them in a directory.  But out of some 100 posts not a single one said that tech support helped them a bit.  So i guess its off to Linux land i go.


#9

hi mate

any chance i could get that link to the forum you mentioned??

josh

p.s keep an eye on this space as i have a mate with extensive knowledge on linux who believes he will be able to access it


#10

Actually, I finally got an answer from technical support and the solution to the problem.  These Q’s are from most recent to oldest.  I am working on it right now.  I am downloading BackTrack 4, which I hope takes care of this.  From what I gather the problem was that I renamed my Music/Photos/Video folders and that is what caused the problem.  So hopefully by tomorrow I will have this sorted out.

Q: Is the problem that my drive is mis-configured or is it the lack of firmware update to correct the problem?  From my understanding it is the media app Twonkie that is causing the problem.  Did I configure it incorrectly?  If I have mis-configured it, where can I find the configuration settings for it?  I want to make sure it doesn’t happen again.

 

A: The Twonky server may have become overloaded and is causing the issue. The configuration settings are in the Network Storage Manager.

If you have not renamed the drive to something else, type in the following into the address bar when accessing the drive within Internet Explorer:

//mybookworld to access the web interface
You can also change “mybookworld” to the drive’s IP address if you know it or prefer to connect to it that way.

Once logged into the Network Storage Manager, please be sure to switch to advanced mode. Once in advanced mode you will be able to select the Media tab and then select the Media server button. Once in the media server, select the Twonky Media Settings. You will now be on the main settings page. Please click on “Sharing” under basic setup. You will now see multiple options on this page for configuration. Please uncheck all 4 “Content Locations” and set the rescan in minutes to 0. After those options have been set, please click the Save Changes button. These settings will prevent the Twonky Media server from scanning your files and potentially crashing the system.

Q: 

Thank you for your quick reply.  From what I gather is that my drive filled up with .tmp files related to Twonkie (can’t remember if that is right).  Once I delete all the files in the \tmp directory the NAS should start right up, correct?  Then I can apply the firmware update that should correct this.  If the update doesn’t correct this then I will disable Twonkie, it’s a cool feature but I don’t want this to happen again.  I was using it to stream movies and music to a DSP and 4 Xbox360’s, so it was getting used a lot. 

My question is if I am able to get the NAS back up is this a problem that the update will fix for sure or do I need to RMA it and get another one?  Will the new one have a fix for this or is there some method I can implement to prevent this from happening again.

A:I would not recommend deleting files from the TMP folder as you may delete something related to the operating system running on the ShareSpace. I would advise you to move your media files from the “Shared Music”, “Shared Movies”, etc. Once those files are moved, please power cycle the unit. You should now be able to access the web-based administration panel and configure your drive appropriately.

Q:  How can I access my files and why don’t you have some kind of whitepapers on recovery from a failure if that is why a consumer purchases it with the RAID 5 feature?

A: If the web-based administration panel is not working, you may still be able to access your data. If you are not able to access your data through CIFS/Samba, you will want to try accessing your data through FTP. We do not have any type of data recovery services or software. Data recovery requires advanced knowledge of files and data structures. We have knowledge on building drives but not recovering the data stored on them. Please see the link below for a list of our Data Recovery partners and how to RMA your device.

 

Hope this helps you out. I underlined, bolded, and italicized the main part of resolution.  Good Luck


#11

Error

XML error: no wixnas object found! Warning: Unknown(): write failed: No space left on device (28) in Unknown on line 0 Warning: Unknown(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0

Unfortunately i have no web access at all to the device

i can see its IP but can’t connect to it at all


#12

Oh man that ■■■■■.

And not to sound Dumb, you did reset the unit right?  Using the reset button on the back of the unit?


#13

Humm never thought about that???  Nah, j/k.  Yeah reset the ■■■■■■ many a times.  They are still helping me with it but I think we just about got it.  Stupid Linux giving me hell of problems, but almost got it figured out.


#14

Community link please


#15

whose been helping you with it?  The community or Tech support?  or an outside person?


#16

technical support


#17

you got more then i got after trying to recover Raid 5 connecting all Drives via sata to usb adapters

raid parameters could not be found

Drive has been completely wiped and lost all data

WD should not make NAS with out a way to recover data

anyone looking to buy a NAS buy a real one from Netgear  (readynas series)

they have the ability to log in to the systems saved firmware and recover data

Never again will i buy a bloody WD NAS

Note: WD stick to what you good at Hard Drives only thats it

how do i make sure this doesn’t happen again, since there is no way to disable the twonky media server


#18

I hear you.  But in their defense it wasn’t WD’s faulty hardware.  It was Twonkies stupid software.  If anything they ought to put in some backdoor failsafe guards to protect the user.  Twonkie should burn in hell… lol… I will put in a recommendation for them to do so after I leave this planet.  If anything I will be there waiting for them. Lol.


#19

i do get what your saying however WD designed and developed this device

clearly hadnt tested it out  but either way i still need to make sure this cant happen again

there seems to be no way to disable twonky


#20

Yes there is a way to fix twonky problem, i don’t know about shutting it down.  In one of my prior posts I underlined and italiciized how to do it.  All you have to do is uncheck the box that sets twonky to scan for files or something to that effect.  In addition, don’t change the name of the folder that stores you videos/photos/music, leave them at the default name. 

I am almost done recovering the raid, i am just not 100% that the command i have to give is correct and if i get it wrong, I rewrite the raid table and i cant take that chance.  So now i am looking for a linux expert to do it and pay them.  I just need to get past this bull**bleep**.  Frustrating because this is exactly the reason i bought the stupid NAS.  They should just put a warning on the box, “If you want to hose your data, this is the unit for you.”