MyBookWorld 1TB Not on network/discovery/ip


I had my WB1TB for a very long time and have never come across any issues until yesterday.

I bought myself a new router for my ever expanding home wireless network, switched the old one off, plugged the new one in, and set everything up ok, except my mybookworld.

At first i could see it on the network from IOS and Androi devices, but could not map it in Windows 7 on my pc. After changing sharing settings on my PC i still got nowhere.

When trying to acces it via IP address i got a ‘XML Error: no wixnas object found!’

Ive read around on the community pages and one post suggested pressing the reset button on the back. i have done this and now i cant connect to it from anywhere.

Power up sequence is normal, the lights are showing a constant capacity gague, but there soesnt appear to be any communication when i plug the network cable into either my pc or the router. (no visibility or assigning of an ip address)

Please help!




I have since pressed the reset button again, and the drive is now assined an IP address on the network.
Still no joy with WD Discovery, still cant map with PC,

IP address shows (from both PC and mobile devices) ‘XML error: no wixnas object found! Warning: Unknown(): write failed: No space left on device (28) in Unknown on line 0 Warning: Unknown(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0’

I have been able to access files and copy to and from the device on my ipad so the drive and contents are still intact.

Thanks for any help you can provide.

After further reading this thread seems to find a resoloution.
I however dont understand it and could use some assistance with steps to achieve the same result.

Please and thank you.


See if the following link helps to Map the unit.

Before you try that, make sure that you reset both devices and that the router is set on DHCP to provide the unit an Ip address.

Thanks for getting back to me.
Unfortunately the link you provided was no good.
The trouble appears to be with the device rather than my network.
Sometimes the drive boots up normally (as indicated by the lights), gets an IP address assigned, but can’t be mapped or accessed via its ip address (XML error detailed above)
Sometimes it appears to boot normally but never gets an IP address.
Sometimes no lights appear on the Ethernet port on the device.
Sometimes it fails to boot and shuts itself down immediately.
I have tried connecting to a different router/network and still the same issue occurs.

The most common sequence it seems, is normal boot up, normal lights on the Ethernet port, no IP address assigned, lights on Ethernet port go out after a few mins.

Some posts I have read suggest that the twonky may need resetting? But I don’t understand enough to be able to tinker in Linux to fix it.

Any other ideas?
Thanks again for trying to help.