System doesnt recognize external WD MyPassport Drive

Hi there,

I`m using a WD MyCloud Mirror for a few days now. I installed everything properly and am able to access to the System.
My Plan is to host all my files on the Cloud drive and to backup on an external WD MyPassport drive.

What i did: plug the MyPassport into one of the USB Ports (i tried both of them) of the MyCloud Machine and try to use the backup function on the online dashboard. So i choose backups > NAS to USB. I find all my NAS folders on the source dropdown, but my USB device does not show up.

Any help or ideas?

best regards - christine

Does the MyPassport show up as a new share?

What you’re doing sounds correct, so something is not right.

Also if you plug the MP directly into a computer, does it show up as it should (just to eliminate an issue with the cable or something)?

My Passport Wireless drive came preformatted in ExFAT and could not be detected when it was attached to the USB port on the My Cloud drive. I’m not sure of the default format of the other Passport drives, but after I reformatted the drive in NTFS and it worked just fine.