New 4TB MyPassport External Not Recognized by WD Drive Utilities

Purchased a new 4TB 2016 MyPassport drive.

Plugged it in via front-port USB 3, recognized by Windows 10 immediately - pre-formatted as NTFS - no issues.

However, for whatever reason, WD Drive Utilities (v1.3.2.2) refuses to see the drive. It picks up both of my old 4TB MyBook externals, but won’t see this one.

If I open up WD Data Lifeguard, it detects all my drives (INCLUDING this new MyPassport) without issue.

Anybody have any ideas?

1 Like

Can you provided the model number of the new passport?

1 Like



1 Like

Get the latest release

1 Like

That worked, thank you!

However, why wasn’t v. pulled up automatically when I clicked “Check for Updates” on v. Kinda eliminates the point of a check for updates button if it doesn’t do so correctly, heh. :smiley:

1 Like

Purchased just before Christmas. same problem 4TB recognised by WD Discovery but not by WD Backup, WD Securities or WD Utilities.

First tried updating software, then unistalling software and re-installing from website. Still not recognised.

Any suggestions?

1 Like