Synching/Date Modified issue

As anyone with a digital life will tell you, multiple backups of your info is key. I have multiple backups of my files, one which syncs to a cloud drive. I had a 2 TB WD My Cloud for 5 years or so. I started ripping my DVDs, and knew I was going to run out of space, so I spent a fair amount on an 8TB My Cloud Home.

I saw the less than stellar reviews online, but all I need this for is storage, as well as getting a file on my phone, whether that’s a password, an old file of some sort, pictures, etc., while I’m away from home.

The app works fine, and I thought no issues with the product (I installed it last weekend and have been adding files to the drive). I was setting up my synching program today (I use FreeFileSynch and have an automatic backup start at 4am), and the same files kept showing up to synch again and again. I didn’t understand the issue. It turns out, when I synch files, the MyCloud sometimes takes the original “date modified” date and copies the same info over to the new drive…but sometimes it doesn’t. Example - I throw some files on my local drive at 5pm. I synch at 4am every morning. Some of the files on the MyCloud have a 5pm stamp from the day before (which should be correct), some are stamped with a 4am the next day modification (the time the file was copied from the local drive). So then, that’s when the synch program gets confused, as some files keep showing up and you get an error message that the file you are trying to synch is older than the one you are trying to replace. A huge PITA.

So to fix the problem, I can manually drag the files to the cloud drive. That defeats the point of the synching program. And even when I do that, if 10 files were originally copied, 5 correctly carried the old time stamp…but the other 5 didn’t, so I then attempt to replace those 5…maybe 3 or 4 of the 5 then bring over the old date stamp. If I keep doing it, all of the date stamps eventually are correct and match the stamp of the local drive. But what a huge pain, and time consuming.

And, one more interesting nugget…any file that is zero KB (for example I have a blank notepad file as a placeholder for a music track that I don’t have in the set - I have some bootlegs that a few tracks don’t exist in that bootleg since those tracks were officially released by the band) automatically takes the timestamp of the time the file is moved over, and no matter how many times I try to copy those files manually, the timestamp is never the old one, it’s always the new one.

Why do I care? Because in the past I could always trust my backups were happening correctly. Now, not so much. My old drive worked perfectly, but the app sucked. I paid $275 for this darn thing, and it doesn’t work properly.

Is there any way to do something to the MyCloud to make it always take the old (original) date stamp? Is this an issue with new WD drives? I tried doing some searching and I think it is a glitch, but I can’t tell for sure. Is there any way to fix, or am I SOL? If I am, I am going to return it, but then I have to format the drive, and I get nervous that even when formatted, someone who gets the drive could possibly recover my data. I have everything on there - not only music - but all my sensitive personal info as well.

Any help or advice would be appreciated. Sorry if this was posted already, but I scrolled down a month’s worth of topics and didn’t see this issue.

no one has come across this issue?

Timestamp is a syncing problem I’m experiencing with My Cloud Home. I don’t know about My Cloud.

I’ve had to resort to workarounds, manual keying, and third-party software.

Sort of a dealbreaker, when you think of organizing all the photos and videos by chronology.

1 Like

I’ve just read your post about the date stamp issue. It is an issue that has also plagued me. I use a 3rd party software to automatically back up my files to the WD drive, but errors are thrown up because some backup files have a later date than the files been backed up. Obviously, my software then questions whether I want to replace these files.

Did you ever find a solution to this (apart from replacing the drive!)? I’m surprised that more people have not responded.

it’s annoying as hell, and no, never got it fixed. My workaround is the fact that I back up my hard drive daily, and I think like I mentioned above, EVENTUALLY the old date stamp works. So, if I have 10 new files added that day, maybe 7 synch the first time my drives synch (usually at 4am every morning). Then, day 2, maybe 2 more files synch. Then, day 3 or beyond, that last file synchs correctly and the backup is complete. The whole HD is a disappointment because of this, the zero KB file issue I mentioned above, not to mention that I hate that stupid shortcut that shows up on my desktop every time I reboot, no matter how often I delete it. I’m not a computer genius by any means, but these three issues make this hard drive a joke, and all 3 should be easily fixable, but WD doesn’t care.