Success #2 Auto-Connecting OpenVPN client (to a pfSense server)

Note: You may want to review my disclaimers in this post.

One of the really awsome things about the My Cloud is the built in OpenVPN support.

I wanted to setup a My Cloud so I could just hand it off to any end user and it would auto-connect to my pfSense OpenVPN server.

I also needed to be able to SSH into the My Cloud once it had phoned home.

(This shouldn’t be too hard to tweak for other types of OpenVPN servers)

Here’s how I did it.

On my pfSense OpenVPN Server

I’m running pfSense 2.1.5 amd64 with the OpenVPN Client Export Utility plugin installed.

Here are my non-standard OpenVPN server settings

Redirect Gateway = checked
Address Pool = checked
Topology checked = (to allow 2-way traffic)

( Questions about any other pfSense OpenVPN server settings are best answered on pfSense’s support site. )

On the pfSense OpenVPN Client Export page -> I Choose my Hostname Resolution

and
Under Client Install Packages -> Inline Configuration -> I click Others

I download a file named something like:

pfsense-udp-1194-OpenVPNUser-config.ovpn

On my My Cloud drive :

I renamed the file to

office.conf

and coped to My Cloud’s /etc/openvpn folder so I had

/etc/openvpn/office.conf

(I use the pscp utility from putty to copy files to my My Cloud device.)

Lastly I tell OpenVPN which file to autostart by editing the default OpenVPN file.

I run

nano /etc/default/openvpn

and change

#AUTOSTART=“office home”
to

AUTOSTART=“office”

( don’t forget to remove the comment # symbol)

and That was it. 

I restared and have a My Cloud remote OpenVPN client that always stays connected.

I can remotely SSH into it (using the OpenVPN assigned IP).

However I can’t remotely access the WebUI yet.

Either the WebUI server won’t bind to the OpenVPN IP or a local security rule is blocking access.

If I ever figure that out I’ll post back.

Hello,

Thank you for sharing this.

"However I can’t remotely access the WebUI yet.

Either the WebUI server won’t bind to the OpenVPN IP or a local security rule is blocking access."

The apache server is binded to any ip including ipv6. However the /UI/ path is restricted to your LAN subnet. You need to modify apache’s settings and add your VPN subnet to the require ip list.

I am here to ask if someone knows how to update openvpn on MBL.

I would like to update openvpn to the latest version.

I intend to connect to my VPN service provider, so My Book Live will act as a VPN client only.

apt throws out all sorts of errors if I try to upgrade openvpn