Success #1 - No more network drop offs

#1

disclaimer: I don’t do cloud. 

My posts are about what I acheived in a Debian shell via SSH

and

may not be a good fit for folks depending on My Clouds built in streaming and backup services.

backstory: I have 2 My Clouds running V4.00.00-607

I use one as a dedicated file server for a small buisness. The other is an OpenVPN, remote backup client.

So:

I had the same trouble with network dropoffs, that I’ve been reading about here.

From an SSH shell I ran the following commands.

update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable
update-rc.d mDNSResponder disable
update-rc.d itunes disable

and all has been well ever since.

Warning: This will disable streaming and media services that many (if not most) My Cloud users depend on.

Credit to post 5 on the below link which pointed me in the right direction.

http://community.wd.com/t5/WD-My-Cloud/Content-scan-never-finishes/td-p/643989/page/2

Success #2 Auto-Connecting OpenVPN client (to a pfSense server)
Can I use alternative software on my My Cloud
#2

Hello,

Thank you for sharing this and also for posting the warning.

“Warning: This will disable streaming and media services that many (if not most) My Cloud users depend on.”

#3

Thank you for the feedback.

I’d like to clarify a bit about what I did.

I originally just disabled 2 of the services.

update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable

 While that resolved my slow performance issues I still had the network drop off problem.

It wasn’t until I disabled these 2 services…

update-rc.d mDNSResponder disable
update-rc.d itunes disable

 …that my drop off issues went away once and for all.

After a month of constant drive use, I haven’t had a single problem.

If I were investigating the network dropoffs, I’d be looking hard at the mDNSResponder and itunes services.

Thanks.