Still indexing after a month

After upgrading to OS5 a month ago, my drive is still indexing. It reached 99% about 10 days ago but I couldn’t access the dashboard after this. Therefore I did a 4 second reset today and got back in. I tried to automatically update the firmware but it said it was up to date so I manually updated the firmware to 5.17.107.

Since then the percentage of indexing went up and down and then began to increase. Now all I’m getting is either ‘Connected (Generating Previews)’ or just ‘Connected’. The activity LED is flickering constantly still and the light on my connected LaCie USB drive does this off and on. This is getting me so cross - my drive has been out of action for a month and I don’t seem to be making any progress despite having 2 Firmware updates in between. Any ideas please?

From your images it shows that the device is working. What is showing under Cloud Access?

The image below is from mine.

I signed into my account.

Mine looks like yours. I signed in earlier today.

Do you use Twonky and what is you scan interval set at? Click on, tap, or activate image to enlarge it.

I’m assuming you have a My Cloud (according to your post history) and not a My Cloud Home which is the forum you’ve posted in.

Anyways, I have a Gen 1 My Cloud and personally, i just disable indexing altogether

So, assuming you have SSH Access , login, copy and paste this to disable the indexing service. (it’ll start again if you reboot)

/bin/sh /etc/rc2.d/S85wdmcserverd stop

there is code to disable it permanently which i haven’t tried yet.

I’m not using Twonky. I would like to just be able to view my files remotely using the WD app. Having said this, I think that the indexing may have finally finished. The front page is saying ‘Connected’ under Cloud Access and I was able to access the dashboard without much delay. Nevertheless, the activity light is still furiously flashing so I am unsure what is going on.

Apologies for posting in the wrong forum. I do indeed have a MyCloud. I think it’s the generation 2 - ends in -10 on the sticker.

Are you able to say whether your solution would switch off access to the files using the WD app or does it just disable the thumbnail indexing? I can live with disabling thumbnails but I would still like to be able to view files remotely.

My Cloud boxes are not secure so I suggest new device to replace it

I can still still access files via my LAN with the indexing off … so that should not be an issue.

Honestly can’t say about the WD app or remote access as i don’t use remote access or the WD app.

All i can say is, try it if you like… and if it’s not a solution for you, then reboot the My Cloud and the annoying indexing service will restart.

Thanks for the advice. I don’t want to go through indexing all over again. However, I’m now having further issues with indexing in any case so I’m not sure what I’m going to end up doing.