[Solved] WD MyBook 3TB & WD TV Live problem


I’ve been using WD TV Live for sometime and recently picked up WD 3TB MyBook USB 3.0

Upgraded to the latest firmware 1.06.15V and the media player doesn’t detect the 3TB drive :cry:

It does recognize if the 3TB drive in converted to MBR and I’m losing more than 700GB. I did soft/ hard reset

the player and the problem still presists, how can I make it work?

Kindly assist.

Found the solution, downgraded to 1.05.04_V and voilà :smiley:

Now WD TV Live works trouble-free with WD MyBook 3TB single partition in GPT format.


how do i downgrade?

db780 wrote:

how do i downgrade?


No Mas - Just tried the downgrade for the 3TB Western drive with GPT format on my WDTV Live HD SDAAN0000NBK (to version 1.05.04_V).  It did NOT work.  Cannot see the 3TB drive at all…  I now await any WDC fixes.  I hope WDC takes into account the new 4TB drives and later…  I have four of these WDTV boxes in my family and hope the fix happens soon…

  The USB drive is a WDC 3TB drive in a KingWin USB3.0 enclosure.  I do not anticipate any problems from this configuration as all my computers (win7 and XP) see this drive on USB2 and 3…

oops, part # is WDAAN0000NBK as needed for this failure…