SOLVED: How to delete Sleepfix - unbrick?

Just like here: Can't access MyCloud dashboard
I installed Sleepfix on my Gen2, restarted and now it is stuck at “The system is booting up, please wait.”. Sadly, I don’t have SSH enabled.

If I open the device and access the serial console, how can I disable WDMyCloud_WDSleepFix_1.0.bin or even all apps from running without deleting the regular user files?

Thanks a lot!

EDIT:
I was able to enter telnet through the usb recovery for Gen2 devices. How can I undo what Sleepfix did?

Just delete /mnt/HD/HD_a2/Nas_Progs/WDSleepFix folder (Or similar. Use [tab] for auto-complete and list available files/folders).

1 Like

Thanks for the reply @Fox_exe!
Can I access Nas_Progs through the usb recovery telnet? Would it be with the user files in /dev/sda2? Or is the serial console my only chance?

I finally got around to trying it and yes - Nas_Progs is in the user volume on /dev/sda2/.
Here are the steps that solved the problem:

  1. Boot into USB recovery as per Fox_eye’s instructions on the website
  2. Find the IP address assigned to the drive in your router (Note, it will be different than the usual one even if you have address reservation)
  3. Telnet into the ip address
  4. Mount /dev/sda2 to a folder and delete the WDSleepFix folder:
cd mnt/
mkdir sda2
mount /dev/sda2 /mnt/sda2
cd sda2
ls -a
cd Nas_Prog
ls -a
rm -r WDSleepFix/
ls
reboot -f

The ls commands are just to see the folders and files and make sure the operations have worked as expected.