[Solved]SSH works but couldn't get access to dashboard

Hello! I don’t know what happened to my Wd Mycloud Gen2. I suddenly couldn’t get access to the dashboard. It shows “The system is booting up, please wait.” SMB also doesn’t work. I couldn’t map the drive and sync files with wd smartware. However, I can open transmission by IP:9092. I can also ssh into the drive. The front light is blinking blue. I have tried to reboot both the drive and router. Neither method works.

I’m hesitating about WDSleepFix in this post WD MyCloud Gen2 - Enable apps install tab + Apps!.

Is there any way to remove it through ssh? Thanks in advance

Edit: After digging for a whole night, I finally solved the problem.

As I have said, it is due to the WDSleepFix. Just simply login to ssh and run the following command:

  • cd /mnt/HD/HD_a2/Nas_Prog/WDSleepFix
  • ./stop.sh
  • ./remove.sh

Then the device will reboot and everything becomes normal again. I feel this is related to the recent update 2.30.181. Hope this helps:grin:

1 Like

YOu should ssh into the My Cloud and run a ps -eaf. See what is running. It would seem that the system has not completed the scripts in /etc/rc2.d Also check the logs in /var/log.

What’s that?

A fix of sleep provided in WD MyCloud Gen2 - Enable apps install tab + Apps!

I actually don’t know what it does.

Usefull! Thanks a lot!

And for those who like me doesn’t have SSH enabled? :frowning: