WD MyCloud Gen2 - Enable apps install tab + Apps!

Plex is updated to:
WDMyCloud_plexmediaserver_11224929,bin

Download:

Are you doing the solution with ssh?
or straight in the browser?

Hi ,
i have also tried this straight in browser and still get same thing with the accept button

Hey @Fox_exe, I am having problems installing the ex2 version of the debian chroot on my ex2 ultra. It gives me a banal “installation failed” message.

In the meantime I will manually do an ARM debootstrap, and hijack the transmission app’s init script to also start the manual debian, but that’s dirty and unpleasant. Would rather have containerized debian like I did on my Gen2 mycloud.


EDIT:

Ok, I have a mostly functional manually debootstrapped chroot with Ubuntu Xenial. Slight issues with systemd shared library not being of proper page alignment, but since I dont want systemd in the first place, I am ok. I will hack into the init script for Transmission to have it automatically start. Would rather have the nice clean debian package installed though.

Hi guys,

Could you please help us on this case ? Mine is in the same situation, and I don’t have ssh enabled.

Looking forwrd to your help

batu

Apparently inaccessible dashboard problem is related with wdsleepfix that I also installed.

How i can terminate sleepfix without ssh access ( as it is disabled on console which I can’t access )?

based on:

Shutting down and turning on solved it ( restart caused it )

When I run QuikFynd, I’m getting Establishing Connection to QuikFynd on your Nas message at the configure screen and it gets stuck.

I tried to run QuikFynd manually through SSH I get an error message:

./start.sh: cd: line 11: can't cd to bin

Is there a problem with packaging?

Just found this thread, because I was looking for a way to get Plex on my MyCloud 2.Gen.

But just from the First Post I don’t seem to get how to install a app on my MyCloud. Where to I have to put the *.bin files from the download? Do I need a general file first? Just running the command stated doesn’t do anything of course?

I already accessed my NAS with SSH to turn some options off, so I would know how to do this but what are all the steps to get Plex on the MyCloud?

Plex is updated. Link above.

Thx!

Hey Fox_exe and the rest of you guys.

i am a complete noob with this. when i run the command in the console it brings up the EULA, but when i click Accept it does nothing. what am i doing wrong. your assistance will be greatly appreciated. All i want to do is install Plex Media Server on my device, but i am stuck right at the beginning… LOL

Hey LamPiR,

Can you maybe help me to get this Plex Installed on my device please.

Nevermind… LOL… way up in the comments i found the trick, but now i am getting uncaught errors

@Fox_exe @LaMpiR Thank you so much for everything! But I can’t see any apps in my app store. I have to install it manually. I know they the shows the apps “apps_xml_gen.php” but how do I install it on my WDMC?

You have to open the console again so F12 for chrome or [ctrl] + [shift] + [i]. Then you type this in the console “APPS_EULA=1; check_app_eula();” and know you have accepted the EULA. Goodluck!

FYI, you can run mksapkg on a 64 bit machine as well… all you need is this:

apt-get install libxml2:i386

Hi @Zeikos, solutions for firmware 2.30.193?
The problem is the same: accept EULA.

Thanks

2 methods available: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Apps/_howto.txt

@Fox_exe Hello, I have a question about WDsleepfix app.
I have installed this app on the device I wonder it works or not.
how it works on the device ? I got WDMC(gen2)