WD MyCloud Gen2 - Enable apps install tab + Apps!


#378

Plex is updated.


#379

I am sorry, but looks like I did something wrong: I could have installed WDCrack_1.2 successfull. But I didn’t get any new features.
My screen is


Should I change someting?
Thank you very much
Vlad


#380

Hi everyone,

It works perfectly! Thx!!

Is it safe to update the installed apps ? If the answer is yes, how can i do that ? Just with a reupload ? It will automatically update an app instead of re-install it ?

I installed Plex from a package downloaded on @Fox_exe server. The Plex interface offer me to download an update, it is a .bin file. What can i do with this file ?


#381

Thank you so much for your hard work!


#382

Where did you find the right .bin ? To update it, we just need to upload it, as if we wanted to install it ?


#383

I have created it. You can check the instructions few posts above, you can do it yourself as well.

Yes, it will show a warming of overwriting the current one and you just go with it and it installs plex.

Should I make a video about it, a lot of people don’t seem to realise how to do it?


#384

Thx. The video could be a good idea! Two things are not obvious :

  1. How to update an app ? (Just need to reinstall as you said)
  2. Where find the .bin, and what to do with the official ones. Does every official .bin (plex, etc…) need to be rebuild ? Is the process the same for all of them ? Why do we need to do that ?

Thx again!


#385

Basically, how to update it would be the point of it.

All other questions are answered here in the forum, just takes a bit of time to find them.


#386

Thanks! I followed this and was able to update my system (fw 2.30.181) to
Plex 1.12.1.4885
:grinning:
I ended up getting Ubuntu to run from the live disk, using the 32 bit version as you noted! I feel like I accomplished something finally!!


#387

I have updated the Plex to version 11214885 and installed on my WD MyCloud Gen2. The link is few posts above on Dropbox.

The links for the app mksapkg don’t work anymore and I am unable to find them on the WD Developer website.

I have to say that I am really disappointed with the WD and would have never bought the device if I had knew that they don’t do anything for the older releases.

I wanted to go for the better model MY CLOUD PRO SERIES PR4100, but will definitely never again buy a WD product which demands their updates and support over time.


#388

You can find the mkapkg here : http://wd.hides.su/fox_exe/Other/WD_Apps_Make/


#389

Could someone please make a video? Sorry, but a total noob here.

I read through this thread and I’m not sure where to start.


#390

I’m on firmware 2.30.181, I’ve tried everything, but i’m stuck at the EULA Accepting Window in the GUI. Retyping the Javascript Commands in the Console didn’t change anything.

[EDIT] I found a Solution for firmware 2.30.181:

$("#AppsDiag_Manually_Install").remove();
var input = '<input type="file" name="f_apps_file" class="file_input_hidden" id="f_apps_file" onchange="apps_manually_install();">Install an app manually</div>';
$("#manually_install_td").append(input);

#391

Hi,
although I have used this new command, the ACCEPT button does not work.


#392

Plex is updated to:
WDMyCloud_plexmediaserver_11224929,bin

Download:


#393

Are you doing the solution with ssh?
or straight in the browser?


#394

Hi ,
i have also tried this straight in browser and still get same thing with the accept button


#395

Hey @Fox_exe, I am having problems installing the ex2 version of the debian chroot on my ex2 ultra. It gives me a banal “installation failed” message.

In the meantime I will manually do an ARM debootstrap, and hijack the transmission app’s init script to also start the manual debian, but that’s dirty and unpleasant. Would rather have containerized debian like I did on my Gen2 mycloud.


EDIT:

Ok, I have a mostly functional manually debootstrapped chroot with Ubuntu Xenial. Slight issues with systemd shared library not being of proper page alignment, but since I dont want systemd in the first place, I am ok. I will hack into the init script for Transmission to have it automatically start. Would rather have the nice clean debian package installed though.


#396

Hi guys,

Could you please help us on this case ? Mine is in the same situation, and I don’t have ssh enabled.

Looking forwrd to your help

batu


#397

Apparently inaccessible dashboard problem is related with wdsleepfix that I also installed.

How i can terminate sleepfix without ssh access ( as it is disabled on console which I can’t access )?

based on: