Solved - G-Raid G-Speed Studio 12 TB RAID and OS Ventura

I built a Ventura external boot disk drive and tested my old G-RAID G-Speed Studio 12 TB Raid with the new operating system. Happy to say it worked!

I can only claim that it works on a G-RAID G-Studio 12 TB RAID.

1 – Building the Ventura Boot Disk; I had problems creating one based on the instructions from the Apple site. I used Howard Oakley’s phenomenal step-by-step guide and his directions (written Nov 10. 2022) worked on the very first try. He did a few things differently than other directions and videos I have seen. I used a G-Mobile SSD formatted on APFS/GUID. I appreciated the fact that he did not use any “Terminal” commands.

Here is the link to the instructions.

2 – Download this file…
Direct Download: G_SPEED_Studio_Software_Utility_200520010.dmg

To find this file, go to, click Software by Product, click G-Speed Studio Utility, click download Mac OS 10.12+

3 – Download this file…

Look for this new driver dated 11-02-2022, V21.1.0-2
Pegasus32 Series DEXT Driver for Apple-Silicon Macs

Hi @Ron_Kabele,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

I have added Ron’s link to my support case.

How can it be that WD hasn’t updated its own support database on this issue and is instead leaving it to customers to fix the problem for them?

So frustrating.