Old G-Studio 12 Tb and Ventura

I have an old G-Studio 4 drive RAID with my New Mac Studio M1 Max computer. I am using the Promise driver and the drive has worked perfectly. But I am getting a message saying that the Promise driver will no longer work with an upcoming osx upgrade (I am assuming Ventura).
Does anyone know if the G-Studio RAID will work with Ventura?
Thanks very much!
Ron

1 Like

Hi @Ron_Kabele ,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:
https://support-en.wd.com/app/ask

I had 2 x Shuttle XL 48TB working fine on my M1 Mac with Monterey after following the instructions provided by WD .
I Updated last night to latest Ventura and my system just reboots on startup when the drives are plugged in. I tried re-running the install process as suggested by WD but this did nothing to fix the issues.

I’ve logged a support ticket - lets see what happens

Any help or advice or experience appreciated -

I just upgraded to Ventura and can confirm that no… it will not work. The Promise Technologies extension causes the system to crash and reboot over and over until Ventura disables it and starts up. Once disabled, my 4-Bay G-RAID STUDIO won’t mount.

I’ve reached out to support for a possible solution. Until then, I don’t have any access to the 9TB of data on my RAID!

How can I otherwise access my data now if there’s no solution?

WD Support just sent me this link.
If you have a chance, could you let me know if it works?
Technically, it doesn’t appear to be a new driver, but rather a procedure to unlock the old driver.
https://support-en.wd.com/app/answers/detailweb/a_id/50057/kw/50057

That’s actually not the message I get. When when it first booted in to Ventura, the machine kept rebooting. Eventually, it said it had to disable extensions that I could manually re-enable in System Settings. In System Settings, I could see the extension that got disabled and when I go to re-enable it and restarted the computer, it rebooted repeatedly until it had to disable the extension again. Now, the option to enable the extension doesn’t even show up.

■■■■. Their solution sounded too easy. Things never seem to be easy with OS X upgrades.
I might build an external boot drive and try it with Ventura.
I am working on a big project so I will hold off on Ventura until it is finished.
If anyone else has luck with G-Studios and Ventura, let me know. if I hear anything else I will post it here.
Thanks!

Well, I ended up getting on the phone with them earlier today and while the problem is still there, there was at least a bit of progress. It seems that there is an M1 driver extension available already. You might wanna try it to see if it works for you. https://support-en.sandiskprofessional.com/

Unfortunately I sent it to trash when installing Ventura - any way to get it back? Any hidden files I need to download?

Do you have direct link to updated m1 driver please Ken, thanks

Tried to type in G-Speed Studio XL but none of the links provided function.

2 Likes

I didn’t provide a direct link because it’s going to depend on your product. Follow the link I provided and select “Download” from the top left. That’ll take you to your options.

https://support-en.g-technology.com/app/products/detailnew/p/107/~/g-speed-studio-xl

I just got this reply from WD tech support -

"Hello Jon,

Thank you for contacting Western Digital Technical Support. Thank you for the additional information. At this time, we unfortunately do not have a work around for why the computer would be rebooting when the drives are connected. We would recommend rolling back your operating system to macOS 12 Monterey for the time being.

Regards,
Matt
Western Digital Technical Support"

This link is from an enterprising reader who discovered an updated driver (updated last week) that worked for his G-Studio RAID.
https://www.promise.com/us/Support/DownloadCenter/Pegasus/Pegasus32/R4

Look for this driver dated 11-02-2022
Pegasus32 Series DEXT Driver for Apple-Silicon Macs

If anyone tries this, let us know if it works. When I finish my project and upgrade my Mac, I’ll let you know if it works for me.

I built a Ventura boot disk drive and tested my old G-Studio 12 TB Raid with the new operating system. Happy to say it worked!

1 – Building the Ventura Boot Disk; I had problems creating one based on the instructions from the Apple site. I used Howard Oakley’s phenomenal step-by-step guide and his directions (written Nov 10. 2022) worked on the very first try. He did a few things differently than other directions and videos I have seen. I used a G-Mobile SSD formatted on APFS/GUID. I appreciated the fact that he did not use any “Terminal” commands.

Here is the link to the instructions.

2 – Download this file…
Direct Download: G_SPEED_Studio_Software_Utility_200520010.dmg

http://download.g-technology.com/software/G_SPEED_Studio_Software_Utility_200520010.dmg

To find this file, go to https://support.g-technology.com/downloads.aspx?lang=en, click Software by Product, click G-Speed Studio Utility, click download Mac OS 10.12+

3 – Download this file…

https://www.promise.com/us/Support/DownloadCenter/Pegasus/Pegasus32/R4

Look for this driver dated 11-02-2022, V21.1.0-2
Pegasus32 Series DEXT Driver for Apple-Silicon Macs