SOLVED - Can't connect to private share - Windows 7 & Windows XP


I have four machines on my network. On my Live Book (current firmware), I have the default public share and two private shares. 

My primary desktop and laptop can access all shares (using my win7 account/password, also setup the same on the MyBook). My son’s desktop (Win XP Pro) and my HTPC (Win 7 Home) can access the default public share but not the private share (they have been setup on the MyBook dashboard with rights to the share). These two machines each their own unique login accounts (not my account).

I want to be able to grant these two machines read only access to avoid any accidental deletions of the content (music). I wish that I could put my photos into a read only share but then the WD Photos mobile app wouldn’t see them (that’s a whole different story). The photos are in the public share and all macihnes/accounts can see them.

If I attempt to map a drive from these two machines or even my own desktop/laptop with the HTPC account or my son’s account, it fails. I do not have any existing mapped drives that would conflict with different credentials.

I have tried to map the drive with either machinename\account and mybooklive\account and neither of them work. I have setup a workgroup on all machines and the MyBook and the workgroup name is consistent among all of them.

Only my account can access all of the shares. Neither of the two “sub-accounts” can access the private shares. My son’s account on his machine doesn’t have a password so I setup his account on the MyBook with none either. I tried creating a new account on the HTPC and setting up the same account on MyBook and no luck. 

Any suggestions would be highly appreciated. Thank you in advance.

Hmmm…  See . . .

Hello, I tried these steps in that post and no luck.

The situation has now gotten worse. I decided to start from scratch and do a factory restore. Now I can’t access ANY private shares. I have tried mapping drives with no luck. Nothing works to access a private share.


This has not been fun at all. I have been messing with getting this up and running for the last 3-4 weeks. I should be enjoying my content now, not still trying to configure it. I don’t want to use public shares because I don’t want my kids to be able to view all content as well as being able to delete files. 

At this point, I don’t know what to do. There aren’t any troubleshooting tools on the MyBook so I can’t determine why there is a problem with credentials.

I think this is why access to my private shares is failing. According to the logs, it doesn’t show me connecting as my user account 

connect to service TestPub initially as user nobody (uid=99, gid=1000) (pid 2648)

It thinks I am the guest account and it won’t authenticate me.

Any suggestions how have my user credentials passed to the Live Book and not the guest account?

Does any one know how to verify that I have an account (via Samba). Although the Web UI says that I have an account, I am not 100% convinced that I do.


After a weeks worth of debugging, I finally solved the issue.

When I tried to use SMBPASSWD to verify my password, I was getting an error. I figured that it’s probably because there isn’t a user account setup (even though the dashboard reflects that there is a user). When I was checking the passwd file (in \etc), it didn’t have my account name listed.

I tried the USERADD command and it failed with “Unable to lock password file”. I did some searches on this and found that I should remove passwd.lock from the \etc directory. I downloaded the file to my machine and then deleted it on the My Book. 

I ran the USERADD command again and it failed with “cannot lock shadow password file”. I did the same procedure as above but with the shadow.lock file. 

I deleted and recreated my account via the dashboard. I tried USERADD one more time and this time it failed with "user erick exists".

I tried accessing the private share and bingo. I got in. I confirmed the log.smbd log and it showed that it was my user account accessing it, not the guest account (named nobody). 

So the lock files (dated 9/28, about how long I have been working on this) locked out the dashboard from making any changes to the actual underlying files themselves.

Note that I wasn’t doing any work with the SSH client before this problem. All configuration changes were made via the dashboard. It was only when I couldn’t get to any private shares that I enabled SSH to do the troubleshooting myself.

I can now access the file shares and prevent access to shares that I don’t want others accessing.

I have posted this so it can help others who may run into the same issue.

Mark your sollution as accepted.  So, to simplify, all that needs to be done is to erase the passed.lock and shadow.lock files then remove and re-create the affected user accounts?

I’ve had an issue recently where the Dashboard UI timed out and thrrw an error but I spied that the scripts invoked by the Dashboard UI were still doing their stuff.