Mybook Live 3TB - locked out of private shares

I’m struggling to get private shares working on my new Mybook Live 3TB.  I can create public shares without problem, but every time I mark a share as private, I can’t open it. Windows Security asks me to enter the network password, even though I’ve never set a password up for this share or any other share!  I’m running Windows 7 64bit btw.

I’ve checked the settings for the share in the mybook dashboard, and confirmed I have full access as admin.  I’ve tried every conceivable combination of username and password, but the share remains out of reach.

The real head scratcher is that if I go into the dashboard and change the share to public, I still can’t access it, for exactly the same reasons as above!  The only answer is to completely delete that share and start over.

Anyone else experienced this?

Thanks in advance,


If you’ve connected to a Public share, Windows will not let you then connect to a private share that uses different credentials.

Disconnect ALL connections to the MBL.

Then connect to the private shares first, then the public shares.

*ALL* shares must be reachable via the same credentials.

Hi, thanks for the reply.  I must be missing something fundamental here, or just not understanding your reply.

Just to test, I went to the dashboard and created a new private share, with user “admin” having full rights to it.  There was no user or password set, just me (signed in as the default “admin”) creating a share, and marking it private.  The share appeared in the MBL as expected.

So, to make sure I really did disconnect all connections as you said, I restarted my computer.  Logged in as usual (I’m the only user on this computer), clicked on Network, and there was the MBL listed, with all my shares inside.  I tried to open the new private share, and as usual I’m locked out, asked for a username and password which was never set, nor ever asked for in the first place.

Is there something really obvious I’m doing wrong here?  All the other functions of the device seem to be pretty intuitive, but this one aspect is really frustrating me!



First off, since you have access to the drive’s UI, enable SSH. This is a great backdoor in case anything goes wrong.

Now that you have a good backup plan:

  • If you are using Windows 7 go to the Control Panel, then User Accounts, then Credential Manager. See if you have anything linking you to the MBL there.

  • If you have any of the shares mapped to your Windows Explorer, remove the mappings.

Once you have done this, then try accessing the drive. You reboot everything again, just to see what happens.

If you still don’t have access:

  • Give the “admin” account a password, by going to the UI and clicking Secure Device in the upper right corner.(sometimes Windows will not accept no password for a login).

You don’t have to worry about locking yourself out, since SSH is enabled there are many users here (and prior posts) who are very good at using the Shell to fix almost any issue.