No acces to private share with admin on w7

I’ve been using my mbl for 5 months now and I am very pleased with this little nas device. Using ssh really improved my understanding of linux commands and I’d never thought that this would be such a powerfull device.

But untill now I only used the public folder. Some days ago I created a private folder and I cannot acces it with the admin credentials. Now I searched on this forum and read several topics but nothing helped even the net use command on windows, because what I understood is that this is a windows issue and you cannot be connected to several shares with different credentials.

I even changed the admin password, but to no avail. Funny thing is, when I create a new user and give the user full acces just like I gave the admin full acces, I can open the share. With the admin credentials it just won’t work. Have I missed something or should I try something else?

Hi, have you tried mapping the private share with WDlink? 

Mapping a drive letter on a WD Network hard drive using WD Link 

No, but I do not want to map it, just access to the share is what I am hoping to achieve.

With the WDlink app you should be able to access the public share, together with the private shares you created. 

I tried the wdlink app and it still wont work because the credentials I give are not recognized.

your windows account is probably access the public share first, and then it will use those credentials whenever you try to connect to any share on that same box.  Do a search on the CMD line for disconnecting all hooks that windows has to that device, and then connect to the private share first.  I don’t know off had, some NET command I think.  Tony was all over that issue.

You can go private then public, but not the other way around.

You mean the net use command, I already tried that several times. Maybe some other ideas?


Search this forum, plenty of answers to your question…


If you would have read my first post, you would know that I already read several topics including the 2 you just gave me…

I did read it, but you did not mentioned which ones. So I provided you with two that solved the issue for other users.