So I'm now having this problem

Continuing the discussion from MyCloud Device Disconnects Itself from the Network Daily:

So now I’m having this problem on mine but it is a little different. Underload it will disconnect and nothing can access it for about 15 minutes then it’s suddenly back online without having reset. I’ve tried resetting it without success. It’s currently configured to use a static IP and it is joined to my domain. Tried updating firmware to the one linked above - “Firmware Update Failed.”

Man I am getting my HATE on for Western Digital …

My next NAS will bee FreeNAS!

After owning this for over a year I have YET to successfully back up ANYTHING to it …

Which firmware revision is the one your unit is currently using? Does a reset address this behavior?


Why do you need a static IP? I have never needed one for anything, ever. DHCP works great for me and my router. Consider doing away with static IP.

One of the recommendations in the prior thread was to configure the EX4 to use a static IP.

FWIW Servers SHOULD have static IP’s especially Domain Controllers while clients should use DHCP. In fact Microsoft Servers log errors when Servers are configured to use DHCP and is not the EX a Server?

And yes, My EX4 in configured to draw user names from my fully patched Windows Server 2012 r2 and that works fine.

Part of my issue is that I’m a software developer and last year after purchasing this EX4, my office launched us on a death march to get the appraisal product out the door ASAP. Had that not happened, this unit would have gone back to the store. Now that things have settled down and I’m not working 90 hrs / week, the return policy of the store has expired and I have time to deal with this nightmare. I have an email from WD with a case # and will contact Ellis today and hopefully, on Saturday, we can work through this issue.

i would suggest using a DHCP reservation for the NAS.

Here it is 2017 and STILL this problem!

But, I may have found a workaround – at least for Windows:

Create a “Quick access” link by doing the following:

  1. Open a “File Explorer” – typically this can be done by Right-Clicking the Window Icon (or “Start Button”, depending on which version of Windows you’re running). In all cases (typically) this button is in the lower left corner of the [main] screen (I included the optional “main” in case you have more than one screen going, like I do. If you don’t, then it’s just the lower left corner)
  2. Select “File Explorer” from the popup list.
  3. OK, this part is a little hard to describe, and may be different for different versions of Windows (I don’t remember – and I’m at Win 10): There is a thin strip that shows the “pathway” to whatever folder you have open in the Explorer. For instance, if you’re looking at the Desktop, it will display something like “ThisPC > Desktop”. Click in the white space to the right of the letters (e.g., in the example, to the right of “Desktop”). This should transform the text into something more like: “Desktop”. Using the keyboard, type the following: “\\DeviceNameOfMyWDCloud” (sans quotes, of course). If you don’t remember the device name of your WD Cloud, or you never changed it, you can find out what it is by typing the following into your browser’s address area: “http://wdmycloud/” OR if you have it configured to use a static IP Address, then simply enter that IP Address. When the Dashboard opens, click on “Settings” (or the little Gear icon), then on “General” (if it’s not already open – probably is). Then, find “Device Name” – which is where your actual device name will be.
  4. Then just hit “Enter”.
  5. Now, click on the text (“Network > DeviceNameOfMyWDCloud”) and drag it to the “Quick access” area and drop it somewhere in the list. If, after you drop it, you don’t like where it is, you can always click and drag it to a different location. Also, be sure to not drop it into one of the other Quick access links – and if it vanishes, that’s probably what happened, so just click into it, delete the “shortcut” and try again (or try dragging it back out and into the Quick access list).

That will establish a link to the MyCloud that you can click whenever you want to access it. I’ve found that even when the MyCloud doesn’t show up in the list when I click “Network”, it DOES show up when I click this link – which leads me to believe this is a network discovery issue and not an availability issue. Also, for my PC, which is directly linked into the Router that the WD MyCloud is connected to (all by wire – i.e. no WiFi), I have little trouble with it. It’s only when we try to access the MyCloud from a WiFi connected device (mainly my wife’s HP Notebook and from Cell Phones) that this issue rears it’s annoying PAH*.

For the MAC, look for a way to create a “Symbolic Link” or something of that ilk (i.e. the GUI equivalent) – I don’t know much about the MAC world, but from my Linux experience (and knowing that the latest MAC implementation is a flavor of Linux), Symbolic Link might be just the thing.

* Punk A$$ Head

Why do you need a static IP? I have never needed one for anything, ever. DHCP works great for me and my router. Consider doing away with static IP.

Might make SSH a bit easier.

i would suggest using a DHCP reservation for the NAS.

I’ve tried both (DHCP and Static IP), makes no difference.

dhcp reservation for sure on network devices.