Smart status not available for a WD20EADS

Good night,

Today I discover a label in the Windows disk management service that tells my WD20EADS (2TB) status was Correct but with warnings. I’m running Windows XP 32+SP3

So I tried to check it’s SMART status with DLGDiag (1.24), but it’s telling me “SMART status not available”, and it’s reporting wrong capacity, 9GB instead of 2TB. In windows explorer the size is correctly reported (2TB).

The DLGDiag quick test just pass fine, and Speedfan seems to be giving me some smart values but I don’t know if they are right. Here are the pictures



The hddstatus webpage tells me my disk is good, the only warning is about “Power on Hours Count”, that’s.strange cause I have another disk older than the WD20EADS that reports less hours, and both are connected at the same time.


Anyone could tell me if the disk is right or there could be any problem with dlgdiag not detecting SMART values?

Thanks in advance!

Check the unit with a full test and the windows check disk utility. 

How to do a check disk:

Thanks ragdexx.

I already do a chkdsk and everything goes right.

The stange thing is now dlgdiag is reporting the disk as a 3326095 GB!?!?!?!?


Could be same problem with my disk? Or something wrong with dlgdiag?

Thanks in advance!

Sorry me again.

I don’t understand, i start dlgdiag again, and now is showing “smart status pass” and once again 9gb capacity.


I also tried with SeaTools but I didn’t allow me to run tests. The only strage thing I see is the “Block Size(Bytes): 5”. Shouldn’t be a multiple of 4/8?


Hope someone could help me understand this. I really don’t know what’s happening here.

Thanks in advance!

WD’s Data LifeGuard sometimes has problems communicating with drives in a Windows environment. The bootable CD version should work fine, though.

BTW, I notice that DLG is reporting IDE mode for your drive instead of the usual SATA. Is this because you selected IDE compatibility or legacy mode instead of AHCI in your BIOS setup?

Your drive’s SMART report looks good apart from the extremely high UDMA CRC Error Rate. This makes me wonder whether your drive’s performance has been reduced from DMA mode to PIO mode. You can verify this in Device Manager. You can also see this in a HD Tune read benchmark, for example (the graph will be a flat line). A high raw value for this attribute normally suggests interface or cabling problems.


As for the Power On Hours Count, your drive appears to have been operating for 16275 hours (= 0x3F93). That’s nearly 2 years, and judging by the Power Cycle Count (0x77 = 119 decimal), it would appear that your drives run 24/7. I see nothing wrong there.

Hi fzabkar, i’m really very thankful for your great explanation!!! I would test with the bootable cd then.

But now I realize I forgot to mention two things. First of all about the IDE thing, the disk is connected to an old motherboard without native SATA support, so it’s connected through a Rosewill RC212 PCI controller card (I didn’t remember that until you mention the IDE thing). Is maybe because of that that dlgdiag is seeing the drive as an IDE?

The second one is some time ago, after a power outage in my home, I lost a 1/4 of the data stored in the disk. I recover almost all of the info with a Data Recovery; but since the disk was almost full and I discover the missing data one day after the power outage, some files were lost because newer files stored in the disk that same day.

Could be any of this things related to the UDMA CRC Error rate you mention? Truly sorry for not telling this before.

About DMA or PIO, I don’t know if I could see or change the mode as the drive is connected through the PCI controller card (the drive connection is not listed in Device Manager as a normal IDE/SATA controller).

By the way, here are HDtune read test. I also attach the info page (the healt page was empty so I suppose hdtune can’t read smart status). But I don’t understand them very well.



Thanks in advance mate, regards!

I won’t be able to see your images until they are approved, but your latest information was enlightening.

After examining your PCI card’s drivers and photo, it appears that it uses VIA’s VT6421 SATA I controller chip:

Originally I was puzzled as to why two “IDE” drives were being seen differently by DLG. It now appears that your 250GB PATA drive is being accessed via Windows’ native IDE driver, while your SATA drive is utilising VIA’s IDE driver. DLG and HD Tune are both having difficulties retrieving the 2TB drive’s SMART data by way of VIA’s driver. I have also seen this issue with utilities such as smartctl (smartmontools), so I don’t believe it reflects any problem with the HDD. That is, I would dismiss this issue as a red herring.

As for the UDMA CRC Error Count, I can’t explain why these errors are occurring, but the VT6421 chip has certain known problems:

The first “problem” is that the VT6421 chip is limited to 1.5Gbps SATA interface speeds, so it may fail to negotiate a connection to a 3Gbps or 6Gbps drive unless the drive’s speed is limited to 1.5Gbps. WD’s drives have an OPT1 jumper for this purpose. I expect that yours would already be installed.

The second issue is that “certain WD SATA II 3 Gbps disks on VT6420 and VT6421 will trigger error conditions under which the SATA controller FIFO overflows during controller-disk communication because these disks do not fully conform to the SATA specification.”

I’m wondering whether the above problem is responsible for the CRC errors. In any case, I would think that these errors would prompt the drive to retransmit the errored data, so I doubt that there would be any risk of data corruption.

As for your warnings in Disk Management, I can’t offer an opinion without seeing them, and even then I’m not sure I could help you.

Fzabkar, once again, thank you very much for your detail explanation, you are a real pro in HDD matters!!!

I don’t know why the images are not shown. But I check the jumper and yes, it’s set correctly. The strange thing is I remember checking the smart status when I installed the disk the first time, but maybe I was wrong.

Do you think another controller card (maybe the rosewill RC 209 with the SiIicon Graphics 3114) would be better? Do you know if exists any PCI controller card (not PCI-E) that allows native SATA 300 mb/s speed  rate (to remove the jumper and make the disk faster)?

One more time thanks mate!

PS: Now I see that this info about the via chipset is also in WD FAQ site

Your images have been approved. I can now see that HD Tune’s read benchmark is indeed suggesting that your drive is running in PIO mode. That would account for the abyssmally slow 1MB/s transfer rate. If your drive were operating at its maximum potential, then the transfer rate would be around 100MB/s or better.

A good benchmark would look something like the following:

Because the “problem” appears to be at the SATA data interface, it is difficult to lay the blame squarely on VIA’s controller. Therefore I can’t answer your question as to whether the drive would perform to its full potential with a different card.

As for returning the drive to DMA mode, apart from editing your Windows registry, you could simply switch to the second SATA port. This should force Windows to see the drive as a “new” device, and it should then revert to its DMA default. You may find that it eventually drops back to PIO mode, though.

To answer your 3Gbps question, I don’t believe you will derive any benefit from a 3Gbps interface speed. Since the drive’s maximum sustained transfer rate is only around 100MB/s, this means that you won’t even come close to the limits of a 1.5Gbps (~150MB/s) interface.

Lastly, I’m not a programmer, but AIUI your SMART software communicate with your HDD’s device driver either via general system calls, or via device specific IOCTLs. One method produces intelligible results, while the other does not. That’s not the fault of the HDD or the SATA controller.

Hi fzabkar!

The problem I have is that with the PCI controller, I don’t get the option to check or change DMA/PIO mode, so I don’t know in which one is running. By the way I already change to the other SATA port available in the PCI controller, but it gives me same speed in HDTune, so I suppose nothing could be change and I should stay as I am :wink:

Thanks mate for all of your help accross the thread!

The OP in the following discussion appears to have had the same problem as you, with the same VIA chip, but with a different HDD brand:

In his case HD Sentinel was able to confirm that his HDD was running in PIO mode. The OP also stated that “the SATA controller is showing up in Device Manager under ‘SCSI and RAID controllers’”.

I’m not certain, but ISTM that a different SATA chip may fix your problems.

As for editing the registry, I would run REGEDIT and go to the following key:

Then look around for likely candidates, or search for “DMA”.


I didn’t found any DMA or PIO configuration in regedit to change :frowning:

But after googling for some time, I think I hav1e found the problem. Or at least I’m having the same behaviour described there.

Is a configuration very similar to mine (Win XP with, old AMD Athlon and MSI k7n2 delta motherboard), with Rosewill 212 and WD 2TB Green Drive. So I suppose that’s the problem with the slow reads and I should stop looking for ghosts :slight_smile:

Thank you for your enlightment in this thread! I’m very thankful.