Shared video folder is not responding

Hi all, I am really hoping someone is going to be able to help me out. I have the my book live 2Tb but i’m having issues with the shared video folder in the public access. When i sign in either using or through the network on my laptop and open this folder to either add or remove videos from it the following happens. I open the folder and thats ok, But when i click on any video  i instantly get the message that the folder is not responding and it just stays like that and never responds. I have tried different laptops/desktops to try this and the same result. Shared music and pictures are fine, Just video! Twonky is enabled. This folder worked fine before and i really dont want to factory reset, I tried the reset button and that didnt help and have also ran a full diagnostic and that was ok too. Also the other weird thing is that the ip adddress for the my book live has changed and for no reason at all. All help is appreciated

If you open the network monitor on Windows, you’ll see that it actually IS accessing the file.   Microsoft does funky things in Windows Explorer, it’s not something the WD is doing.

Hi, Thanks for the response. I checked the network activity in windows task manager and as soon as i touch one of these video files it goes up to 50% and just fluctuates around that number. The thing is it’s not just this laptop, Its every laptop or desktop i try. It never done this before and i cant see a reason for it now.

That behavior is “normal” for WebDAV (WD 2go) connections; it’s been that way for as long as WD 2go has been around.  It’s the way Microsoft works with WebDAV connections in Explorer.

Any idea what i’m supposed to do then, I can no longer add or remove these files and because it stops responding, The weird thing is the shared music file is fine

If you wait long enough, it will respond.

You can also try using different “views” in Explorer, or using a non-explorer file manager like teracopy or similar.

It never responds, It just hangs. I left it for over an hour yesterday and ended up closing it with device manager. i have considered making a new shared video folder and adding files to this, If this works then great, But that also leaves me with a folder that cant be accessed with around 20Gb of video.

I know it’s been a while, but I stumbled across something that may be the cause.

BEFORE you connect to your drive via WD 2go, go into Explorer, try turning OFF the “Preview” and “Details” panes by clicking ORGANIZE – LAYOUT.

THEN connect to WD 2go and see if that helps.

You can always re-enable the panes when you’re done with WD 2go if you need them.


Thanks for your idea. I never had preview and details on so i tried it with them on and then with them off again, No joy, as soon as i open the shared video folder and click on any video it instantly goes to not responding and hangs and never responds. I even tried a quick and full factory restore but that didnt work either. The wierd thing is when i play the video through a console or tablet it plays fine. I just dot understand it, Tried a different browser system too but that didnt help. i purchased this over a month ago, Had to take the 1st one back as the firmware update failed and got a replacement. I have over 500gb to put on this drive but i need it to be stable. Any other help is greatly appreciated.

Bring up RESOURCE MONITOR (included with Windows)

Then click the DISK tab.

Then SORT by READ (B/sec)

When you click a video and wait for a few seconds, does the file you’ve clicked go to the top of the list?

Tried that but it didn’t appear in the list.  I only have Read (B/min) and Write (B/min) I am using vista, This happens on all pc’s/laptops in the house. I am even considering resetting my Superhub to see if thats the problem. But i have no problem with opening the shared music or documents folder and accessing files in them.