Safepoint problems, yet again

Let me start by saying I hate this device so much; I am currently in physical pain due to the mental anguish this one device has caused me today. I have owned this 6TB single bay Gen1 for a few years now and I can’t wait for the day I can upgrade to a new device.

I have recently been updating many files on the device. And the device does not like this at all, after a few hours it starts running incredibly slow and last night triggered the flashing yellow light for high temp…the drive became totally unresponsive, no web gui, no ping, nothing. So, I had to power it off and put a fan on it. Awhile later I powered it back up and it was running fine except…

My Safepoint is gone. The safepoint share is still present and attached USB drive still intact, but no Safepoint detected. I tried ejecting and reconnecting the external drive, which initially showed a 0KB device for like 30 minutes then finally detected it normally but, still no Safepoint.

I tried to re-create the safepoint but of course, I get the error that the name I specified is already in-use since the missing safepoint is still there…somewhere…I just can’t see it in the gui.

I gave up and created a new Safepoint and moved the data contents of the old safepoint folder into the new one so it wouldn’t take 3 months to rebuild. Which at first seemed to work but now, it looks like I will be getting errors for the rest of this device’s life. In the gui it shows “This safepoint is in an invalid state, try updating to fix the problem”

In wdnas.log it shows that “rsync failed with error, 23” and that it is also trying to update the old safepoint which is no longer shown in the gui, a phantom safepoint that I am not sure exactly how to remove.

I have now identified a specific directory that it is hanging on and not updating during the backup job. If I try to create that directory manually in Windows it fails and says there is an I/O error. I can create a new folder and name it anything except the name of the folder that is not being copied and it will be created fine. So, my next trick was to go to the source, and give that folder a different name, genius, right? Nope, now the backup job still hangs trying to copy a folder that no longer exists.

I have also found the .info file in my old safepoint folder is pretty much empty, only 3 lines, looks like maybe the file was open when the drive went yellow light status and when I turned the power off it wiped out the file. Might try to rebuild it using my new safepoint’s .info as a guide, I just need the gui to recognize the safepoint so I can delete it. And my new safepoint’s .info file references the directory that is hanging, looks like it will always go to this directory when trying to update…I’m hesitant to change this path, not sure what the outcome of that will be.

If any have any advice about tinkering with the .info files, or other tricks to repair safepoints without starting from scratch, I’ll appreciate any tips.

Beyond that I know the best advice is to get something else and abandon this terrible piece of hardware, I just don’t have the funds for what I really need yet. I could get another NAS that is similar in size and migrate some of my data to it and continue using this 6TB mycloud, since it has a 6TB external for backups but, I think I would rather spend a ton more money for a bigger NAS just to be done with the mycloud. A $240 device that I just want to beat to bits with a sledgehammer, best use I can think of for it, if I can afford that.

Are you sure you have a My Cloud Home, your topic doesn’t sound like you do?

1. Front LED
The front LED on My Cloud Home devices is a single color, white. It is either on, off or blinks
with a certain rhythm to indicate a specific “System Condition”. A “System Condition” list is
outlined below in Table 1.2.

See the User Manual, you can find it here.

Not a “My Cloud Home”, which is why I didn’t call it one. It’s simply a My Cloud “Personal Cloud Storage” Gen1, the rounded one, not square, single bay 6TB.

It has a front LED that can be white, blue, yellow or red and solid or flashing will indicate certain things as referenced in my manual. The link does lead me to a newer version of the manual however, it is not correct for my device. The OS pictured is not the same version as my device and although my device is on firmware v04.05.00-342, this newer manual is not correct to my device, but my older manual is.

I was able to use the .info file from my new safepoint to re-create the .info file for my original safepoint that vanished, and then the gui was able to detect the original safepoint. So, I was able to delete the original safepoint, re-create the safepoint again and move the backup data back into that directory with the exception of the problem directory, and run a manual Update. I then deleted the newer safepoint since I no longer needed it and it was removed as far as the gui/os can see but, the empty directory structure leading to the problem directory still remains on the hard drive. If I try to delete it in Windows it gives an I/O error message, trying to delete it from mycloud ssh cli at first says permission denied but then chmod 777 on the directory fails with input/output error.

I didn’t have the time/patience to remove the drive to move it to a PC to error check/fix it, and I didn’t feel like unmounting it and trying to run badblocks on it, not sure if that even works on this device and I’m not going to run badblocks -w on it anyway because it has data on it that I’d like to keep intact.

Once I get another NAS to migrate and move my larger data set onto, I’ll keep running this device for less used files and then I can fix and if needed completely rebuild and re-format the backup drive down the road. Until then, I’ll just try not to breath on this NAS for fear of it malfunctioning.


The first gen v4.x single bay/single drive My Cloud Safepoint feature (and Backup feature on v2.x single bay My Cloud devices) is what it is. Like it or not the Safepoint feature can fail to create or copy files to the attached USB hard drive. Most times it works but in rare cases it just doesn’t. The few times a Safepoint failed was due to either files in use or issues with the USB hard drive itself.

For what ever reason the My Cloud can be very picky on working properly with USB hard drives. Personally I found that I had to ensure my USB hard drive had one single partion filling the entire drive and that it was formatted for NTFS.

There are past discussions on issues with Safepoint and workarounds to the issue. I used the Rsync option detailed in the two following discussions for several years rather than Safepoint.

There is also the GoodSync option that might work depending on one’s needs and settings.

One also has the option of just using third party software to copy the My Cloud user files to a local USB drive or hard drive on the local computer as a secondary backup method. Personally I use freefilesync to copy my data files from a My Cloud to a USB hard drive as a secondary backup method in addition to the rsync script that backs up the My Cloud to a USB hard drive attached to teh My Cloud.

@Bennor Thanks for some useful info!