Safe Point Warnings and Failed Backups

Hi All,

I have been trying for some time to complete a Safe Point Backup from a WD MyCloud 3TB to a MyBook Live 3TB.  Both systems are updated to the latest F/W and connected via the same Gb switch.  My client machines are two Macs.

The MyCloud has a mix of music and documents, copied to the drive via AFP from a Mac, as well as two, small TimeMachine backups - all in, about 540GB of data.

I’ve tried resetting the target drive to factory defaults, but haven’t done the same with the source, as I have a lot of data on it and want to avoid re-copying 1/2 TB of files.

The Safe Point seems to actually copy the 540 GB of data to the MyBook Live (I can see it taking up the space in the share), but starting form scratch always yields the following on the MyCloud web app screen:


Your safepoint cannot be created due to a failed request.  Pleas try creating your safepoint again. (36123)

Along the way, I receive notification e-mails:

(during the backup)

Following events are generated on your WDMyCloud .

Event title:There was an error updating your safepoint.

Event description:5 - There was an error updating your safepoint WDMyCloudWeekly on the SafepointBackup share on MYBOOKLIVE.


Event code:1102

Event time:03-02-2014 02:00:07 AM

Firmware version:03.03.02-165

(after the backup fails…)

Following events are generated on your WDMyCloud .

Event title:There was an error creating your safepoint.

Event description:2 - There was an error creating your safepoint WDMyCloudWeekly on the SafepointBackup share on MYBOOKLIVE.


Event code:1100

Event time:03-02-2014 09:49:17 AM

Firmware version:03.03.02-165

I really want to make this work, because I want transition from Dropbox to WD MyCloud for storage and remote access of files - the WD app works really well on my iPhone, Android and Mac and I’m tired of paying Dropbox.

But without being to reliably backup/restore the WD MyCloud device, I am nervous about trusting it with my files.

What can I do to help?

Thanks,  Ken

One more detail to the above post:

On the web console, if I dismiss the Alert dialog, the web app tells me that my Safe Point is in an invalid state.  If I click the Update button, it returns to copying data:

Currently Copying /iTunes/

540 GB / 540 GB (99%) copied

…iTunes is an empty, private share (I haven’t copied any files into it).

After some time goes by, the Safe Point starts over from the beginning, duplicating the backup onto the target (i.e. there is still 540 GB of data and new data starts copying over).

Is this system compatible with Mac OS X?

I am a happy user of the safepoints, although my experience suffered from various USB/safepoint issues. I didn’t get specifically your error, but various errors about safepoint outcomes.

Here is a basic troubleshooting of safepoint process:

  • delete the current safepoint from the Web admin,

  • delete all data from the target disk

  • run a system test on the target disk to make sure there is no issue with the target. I don’t have the same disk as you have, but I imagine there is a way to test it

  • do a “system only” system factory restore (under utilities) on the MyCloud. This will leave your data intact, but your user configuration will be reset.

  • create a new safepoint.

Consider that Safepoint copy speed is apparently limited to something like 10MB/s. Depending on your network and PC configuration you might get faster results by using some sync software on your PC instead of Safepoint, even with the data going back and forth between the PC and the devices. Of course, the benefit of safepoint is that it runs without a PC. Your mileage will vary.

1 Like

Thanks for the advice.  I wish someone from WD would chime in on why I need to “do a “system only” system factory restore…”

I’ve done everything else on the list, but SSH’ing into the box and seeing rsync running, I wonder if Safe point is using SMB underneath rsync.

My belief is that there are one or more files I’ve copied onto the box using APF that are not valid with SMB (filename too long?), but the lack of error details from Safe point makes this difficult to determine.

When I look at /var/log/wdnas.log, I see a number of lines like these:

Mar  1 01:51:31 WDMyCloud logger: ERROR: SafeptRunHandler(1845): 279631913977793

863806953219238200480503: Cannot get permissions for '/DataVolume/shares/Public/

Shared Music/iTunes DLNA/Pop/Ke/Animal/14 Animal.m4a’

There is an artist (I use that term loosely here :slight_smile: called ‘Ke$sha’ and Safepoint is mis-reading that as “Ke” and stopping at the dollar sign.  And, I noticed that the timestamp roughly corresponds to the first error e-mail I received from the system (as noted above).

Of course, I can find the folder above and rename it, but I have a huge collection of music and a lot of classical music with long file names.  I don’t understand why Safepoint has to start over or call the back-up invalid if it misses a few files and then recreate the complete backup, duplicating the disk usage.

BTW, there is nothing invalid about ‘$’ in a foldername with either AFP or SMB/CIFS, so the problem is really with Safepoint not escaping the ‘$’ in the filename.

So, WD is leaving it to the user to SSH into the box, search the logs and find the problems on his/her own…

So,  went back though the logs and it really all comes down to mishandling files / folders containing a ‘$’ character.  The Ke$ha example was a fluke, but I also have a number of source code folders that contain compiler targets for Android, which have lots of names like: R$menu.class.

Anything with a ‘$’ is being mis-handled by ** SafeptRunHandler, probably as part of exec’ing rsync, and it blows up Safe Point.**

Maybe someone from WD can look at the SafeptRunHandler  shell script or program to see if they are properly escaping shell characters that are valid SMB/CIFS chars, but not usable in shell commands without escaping.

I had some issues with safepoint at first as well.  I backup to a usb disk.  I run OSX as my laptop OS.  For some reason it would not finish completely until I formatted the USB drive to Mac OS Extended.  After that it completed fine.  It sounds like you may not have that option since you are backing up to a network storage volume.  Hopefully they fix the issue for you.

I have the 2TB mycloud.  This allowed me to purchase two 2TB USB drives.  I keep one attached at all times for nightly backups.  I keep the other one in a fireproof safe and attach it once a month for a monthly backup.  An option may be to sell your backup NAS and purchase USB storage for the task.  But I realize it would require sacrificing your current solution that “should” work fine.



^^^ "I had some issues with safepoint at first as well.  I backup to a usb disk.  I run OSX as my laptop OS.  For some reason it would not finish completely until I formatted the USB drive to Mac OS Extended.  After that it completed fine. "

Wait, you mean you can format your USB drive as Mac OS Extended (Journaled) and attached it to your WD MyCloud and then use that as the Safe point target?  I will try that and see what happens…

But, if you read my previous post carefully, I don’t think that will change anything.  The shell script that is running rsync is choking on the file names with ‘$’ characters and I doubt that the target disk matters, at that point (i.e. the SOURCE is getting errors trying to read the files and invoking rsync).  Again, ‘$’ characters are LEGAL on both Apple (AFP) and Microsoft (SMB/CIFS) volumes, but will cause problems with shell scripts.

Your post intrigued me and I checked my safepoint data. On my system, the files (and folders) where the name is containing a $ sign are copied correctly.

…and you are not receiving any errors during Safe point updates?  Are you copying to a USB drive or to another WD MyBook or MyCloud?

Thanks, in advance, Ken

Now running Safepoint backup to a USB drive connected to the MyCloud.  I formatted the USB drive as Mac OS Extended (Journaled) before attaching, as someone earlier had suggested.

SSH’ing into the MyCloud, I still seeing these in the /var/log/wdnas.log files:

Mar  4 17:21:59 WDMyCloud logger: ERROR: SafeptRunHandler(1845): 93613546667431063808498278558611411703: Cannot get permissions for ‘/DataVolume/shares/Ken/Documents/Company/TrunkPC/edis_maroon_code/project/target/streams/compile/ defined-sbt-plugins//out

…where the bold area is missing a folder called: $global.  The folder is definitely there, the file underneath is definitely there and is readable by everyone.

So, I then went into the matching folders above on the USB target drive and the files are definitely on the target drive - same size, permissions, et al.  Clearly, the Safepoint process is backing up the files.

We’ll see what happens at the end of the backup - I’m 7% complete, with 40GB / 540 GB copied.

I am copying the safepoints to a USB 2.0 disk attached to the NAS, formatted NTFS, if that matters.

Success is achieved!

So, I guess it has nothing to do with resetting my source system to factory defaults - Safe point really requires the target device to support the same file system used to write the original data.  So, by formatting my target USB disk as HFS+ (Mac OS Extended), all is well, since the source disk has things like TimeMachine backups and files/folders written out via AFP from my Macs.

For Safe point going to another MyBook / MyCloud device, as a NAS target, the default is to copy using rsync over SMB/CIFS and then errors occur with Mac -centric data.

So, wouldn’t it be nice if the WD MyCloud could handle that case and allow me to replicate to another WD MyBook Live? Maybe by offering to replicate with rsync over AFP instead of SMB/CIFS?

Anyway… I am running now with replication.

 Anyway… I am running now with replication.

Well, almost.  The attached USB drive (WD My Book Elite) went to sleep, as it does by default, and the MyCloud didn’t/couldn’t wake up the drive.

I restarted the MyCloud drive the night before a scheduled Safepoint backup and it ran correctly after that; I will keep watching this.

@ Krutsch,

Two sleeping Giants is a no, no. ;-):smileyvery-happy:

If one wakes up, it will beat up the other and visa versa. Asking the other, WHY did you wake me up, I was sleeping !

Obviously the My Cloud should send an “Ack” to the sleeping WD My Book Elite so it wakes up and then the WD My Book Elite says “Synack” and then start to Safepoint excution. I guess that is not in the Firmware either.:laughing: on USB level that is.

I guess WD never does all the scenarios with their existing hardware connected together and figures before hand out whether it works or not. :wink:

Thanks for the tip. I had to power cycle the MyCloud after the last FW update (as described above) and I will see what happens before my next Safepoint backup.  I really want to let the attached USB drive sleep, as this is all it does and I only run the Safepoint weekly - the USB WD MyBook Elite really vibrates/hums when it’s running and would like to avoid the noise if I diabled the default sleep behavior.

If the system settles down and works well, I may replace the USB with a small portable USB 3.0 drive that will take up less space/power and be quiet.

@ Krutsch,

Dear sir, you can put your WD MyBook on a thick rubber mousemat  or stick rubber dots under it on the four corners and the hum will be gone. Unless there is ventilation problem, this is the solution. I do this with all things that hum and buzz.

You should let the My Cloud make Safepoints every night at 3-or 4 am, when you sleep. Then it does not have to make too big backups.


PS I have got the USB drive run 24/7. It;s not a problem. As long it stays cool. They can run 1,000,000 hours mtbf. That’s 114 years having the thing on 24 hours a day. Not that that is going to happen, but who is using a drive more than 10 years ? And the WD RED has a 2,000,000 mtbf rating.

And all that sleeping and waking up is not good for the motor spindle. Usually an engine runs its best when it can run and run and run and have an oil change once and a while. It’s the switch on and switch off cars that give trouble.

@ All,

If anyone does not like buzzing noise, then rip out the HDD’s and put a SSD in it. No more noise. :wink:

@ Krutsch,

I guess you don’t like such sound either.


I have the same issues…same error.  Cannot log into the UI and creating a safepoint results in an error.  I have 750 GB of data I need to back up!  

Here is my network:

My wireless network is connected with a Cisco router WRT120N as shown at the following link:

I have wondered If I need to upgrade my router.  I also connect with a Engenius ENS202EXT used as an access point in my home with the goal in mind of extending coverage throughout my home. Here is the link for that device:

Also might be worth mentioning, I connect the EnGenius into a wall power adaptor, instead of hard wiring into my router.  

I think MyCloud is a great idea and my whole purpose for getting it is file sharing via email link, etc.  Also, I want to be able to share files with multiple computers within my home network.

As my network stands right now, I have a 3,000 sf home and able to send a signal, streaming video content to all areas of the house, even multiple computers/tvs at the same time. It is only with MyCloud that I am having issues!!  I have made a safepoint of my data at one time, but it was quite painfully slow.  I needed to wipe my backup disk I was using clean and then make a new backup on it, yet I am lucky if I can log into the UI much less make a back up (safepoint).

I’ve had the same issue of not being able to create a safepoint.  This complete process takes some time (about 6 hours) and did worked for me.  Thanks for the detailed steps.