Request failed due to a fatal device hardware error

Hi , I have a 2 TB WD My Passport external drive, here is the error I am getting "request failed due to a fatal device hardware error ".
There is no noise emitted from the drive, light flashes like normal

Here is a list of what I have done to date:
changed USB cables multiple times (no drive recognized)
plugged in to other computers (no drive recognized)
used CHKDSK and other command prompts, Admin level (the drive not recognized)
used partition recovery software (EaseUS, iCare, Minitool etc…)(only Minitool recognized a 0MB RAW drive, no recovery of partition or files)
Windows 10 Disk Management Console (drive recognized but all options greyed out, so the drive cannot be initialized or renamed)

Can I recover files or most importantly can I repair the drive?
I would appreciate any help, Thank you

Hello avengers11,

You can refer the link provided below for creating an RMA to replace the drive, if it is not showing up on your computer after changing the USB cable and using it on a different USB 3.0 port of the computer.

Refer the link provided below for more information to create an RMA.

https://support-en.wd.com/app/answers/detail/a_id/10336/kw/RMA

Hello Neo33

This drive is not under warranty, the drive is a few years old, and no receipt.

The Staples store would have replaced it but the 2TB My Passport was discontinued, so they offered no help.

I have tried many different connections, nothing works.

I have tried file recovery programs to identify a drive, the drive spins but is not recognized.

To put this in perceptive, I have many WD drives and this is the only one that failed.

I guess I was hoping there would be a small repair or replacement cost for a new drive.

Thanks