Remote access for video streaming with Kodi

#1

Hi, I’ve spent days looking for a way to do this, and I can’t be the only one. 
So I want to be able to stream unpacked video content from my NAS to multiple remote networks. I.e. when I’m at my parents house or my brothers house I still want to be able to stream video just like I do in my home network. In my home network I use a media player running XBMC which connects to My Cloud using Windows network(SMB), but that wont work remotely. I don’t know if Kodi will function better or worse depending on how I connect, but it seems to support a lot of different connections like HTTPS, FTP, SSH, or should I go for a VPN? Though I don’t want to pay a montly cost to a VPN host…   

I’m looking for the simplest way to get this to work, any suggestions?
Thanks!

#2

Your question is probably better served to be asked in the Kodi support forms since its not specifically aimed at the WD My Cloud device. But in sort there are a variety of ways to access a Kodi media server remotely. From using FTP on the WD My Cloud, to using a free OpenVPN client/server setup, to using software like  Bubble UPnP Server on the Kodi box and the Bubble clients on remote devices.

Here is one recent thread over in the Kodi support forums about remote access: Access Kodi Library via Internet (away from home)

Note that FTP generally is not secure and the access information is typically sent in the clear. There is a way to modify the WD My Cloud OS code to setup a secure FTP server on the WD My Cloud. See the following link for more information: [HOWTO] Securing ftp server with encryption

1 Like
#3

This might help:

http://community.wd.com/t5/WD-My-Cloud/access-mycloud-ex2-outside-home-with-SONY-BDV-E380-homecinema/m-p/895368

#4

A lot of great tips, thanks. 
I’ve been trying to set up an FTP server and wanted to secure it, but as I’m a total beginner at this, I don’t understand the “HOWTO” guide; can I use putty to ssh to the NAS? I am able to login but then when I try to enter the first thing:

[root@wdmycloud] openssl req -x509 -nodes -days 365 -newkey rsa:1024 -keyout /etc/ssl/certs/vsftpd.pem -out /etc/ssl/certs/vsftpd.pem

I get [root@myXXXcloud]  not found. Am I missing something?

#5

Before you do anything, I would look into your home where the NAS is located ISP upload speed.

I would never attempt such connections from my home, and I have 60/6Mbps

#6

Yes, fortunatley every connection that I use will have fiber connection with 100 Mbit down, and the NAS has 100/100 Mbit connection. Hopefully enough.

#7

hmmm really? Make sure… the fact that you only mentioned download speeds makes me wonder… the big item here is the upload speeds, not downloads.

That does not seem right for home usage, downspeeds are not usually the same as uploads speeds.

For enterprise maybe.

Also, do not confuse ISP speeds (WAN/Internet) vs LAN (NAS, PCs, tablets, home devices)

#8

 I get [root@myXXXcloud]  not found. Am I missing something?

I suspect you’re actually typing ‘[root@myXXXcloud]’ in the command… DON’T: it’s meant to be showing you the command prompt…

Frankly, if that’s your level of understanding of Linux, I’d go and get some practice elsewhere, otherwise you are likely to brick your MyCloud. That’s an honest warning, and not trying to be rude.

#9

Not to worry, ADSL is going extinct here in Sweden, due to massive fiber installations and you usually buy at least a 100/10 Mbit subscription (meaning 100 down and 10 up). The NAS is in my apartment and the entire housing association has the same internet subscription (included in the rent) which is a 100/100 Mbit fiber broadband i.e. 100 Mbit down and 100 Mbit up. Last time I checked, it delivered 114 Mbit down and 93 Mbit up.

#10

Hi, 

I was facing a similar scenario to yours. I run Kodi in a Raspberry Pi using Raspbmc (now migrated to OSMC) that reads the mediafiles stored in MyCloud via NFS. I wanted to be able to access my media from remote locations and I opted by installing a OpenVPN server (totally free) on the Raspberry. Also installed OpenVPN clients on my android phone and on my laptop. Once connected to my home network via VPN I’m able to access all the files in the NAS using normal file explorers. Also I have Kodi installed on my devices and they access the Rasp’s Kodi shared library through UPNP.

If your media center is always ON and allows to install OpenVPN it might worth a try. Also you could also try to install the VPN server on the NAS. I didn’t try that because in my scenario was safer to do it on the Raspberry (a simple backup of the SD card allows to restore the system in case of disaster). I didn’t find much documentation on installing OpenVPN on MyCloud and I don’t know if it could brick it, be cautious!

Another advantage of setting the VPN up is you can encrypt and redirect your internet traffic to your home connection when connected to public, unsafe, WiFi networks.

#11

Haha yes cpt_paranoia you are right, thank you for your honesty. I also realized the mistake and it turned out that I had a typo in my line. After doing some basic read up I got to the last part i.e. 

[root@wdmycloud] service vsftpd restart

Here I get: service: not found again, as I understand it’s usually got to do with root access but I am logged in as sshd so it shouldn’t be the problem?

#12

Hi ruben.808 I looked at the OpenVPN solution but it seemed as if you only got 500 MB free and then you had to either pay or get friends to subscribe to get more data?

#13

Hi bannedlabel

Probably you are looking at any of the VPN services offered by openVPN, where they host the VPN server and you access to internet though their tunnels, and that has a cost, but that’s not what I meant.

The solution I set at home is hosting my own VPN server installing and configuring the openVPN software in my hardware, and that’s free. Take a look at the community section on their site where they have instructions on how to deploy your server and clients.  You can also find good tutorials on the internet searching ‘how to install an openVPN server on XXXXXXX’ (xxxxxxx being your device). Quite challenging task, but I managed my self following those instructions.

#14

I use OpenVPN install on my NAS.  But it is very slow.  The VPN encrypts all teh data which slows down the processor a lot.  Painfully slow for any files of size - especially for video and audio files - impossible. 

I’m still looking for how to have the DNLA server (Twonky 8 in my case) serve the content to the internet.  That way i can take my Kodi enabled device with me when i travel and still have access to my media on my NAS. 

#15

So I guess I’ll try ftp first and see how well that functions, but I still need to secure it. I haven’t figured out why I can’t run the ‘service vsftpd restart’ command even though I logged in as sshd. Is there another way to restart it?

#16

You could try just starting it; it may not be running to restart… Though I’d hope it would be smart enough to figure out it needs to be started.

#17

Tried rebooting the NAS, but it seems I have bigger problems than that, for some reason the vsftpd.conf disappears. It should be under /etc/vsftp.conf but it isn’t? Then I wanted to check if the vsftpd.pem was still there, which is under /etc/ssl/certs/vsftpd.pem but wasn’t able to enter the ssl folder?

#18

I’ve been playing around, trying to find a solution to this.  I think i have.  

Get a very good modem like a Asus n66u, and turn on its native OpenVPN server.  The processor on teh Asus is big enough that the VPN connection is fast.  Next install OpenVPN for Android on the Kodi device. I use a Amazon Fire Stick, so this worked fine.   Set up the VPN config on the Kodi device, and it works very well.  Of course you need a lot of upstream bandwidth to serve big video files.

#19

I think what this person really wants is something like a Plex Server.
I would research setting that up with all the content.
Kodi really isn’t meant for that.
You can handle multiple people at one time with Plex also allowing to you share you Plex with family not just use it while out of town.

#20

there is a free plex app in kodi allowing you to access all your plex content there also so you and family can access your plex server in kodi