Red light on drive bay one goes away after reboot

I have a MyCloud PR4100 that is about 3 years old and has worked great. Two times in the past 4 months, the red light underneath drive bay 1 was solid red and the status page indicated a critical issue with drive #1. Each time, I rebooted the enclosure and the red light went away (for over three months the first time and now two days after the latest incident).

Is this just a glitch or should I replace Drive #1? Would rebooting cause the light to turn off if it was really a hard drive failure? There are currently no SMART nor drive errors showing up on the “Storage” page of the MyCloud web interface–although there was a red exclamation point next to drive #1 before I rebooted.


You may want to either move your post to the OS5 Pro Series subforum or start a new post there. People in the Pro Series subform may be more familiar with your device and may be better able to assist.

OS5 My Cloud Pro Series

If one hasn’t done so already one may want to run a full system test to see if any errors are discovered.

My Cloud OS 5: Perform a Quick, Full, or System Test

Hi - did you get a solution to this issue.

I have a WD EX2 Ultra fitted with 2 Ironwolf Pro 8TB Drives. Originally it was set up for RAID 0 but then I got the red light on Drive 1. It did go off after a reboot but then came back a day or two later. I decided to switch to RAID 1 for safety and after doing so I RMA’d the hard drive back to Seagate. I fitted the replacement drive when it arrived and rebuilt the RAID (Yawn) and it worked fine for a week and then bingo - the red light came back on Drive 1. Again it goes away after a reboot.

Now I’m pretty sure the drive is OK and I think it must be a glitch with the WD’s firmware. Everything is backed up and it’s only media for personal use anyhow.

1 Like

No. The red light will pop up from time to time, but it always goes away. I’m chosen to just ignore it.

Something very fishy has gone on as after the last firmware update I’ve not had a single issue with the Red Light on HD1 - I think WD knew there was something wrong and fixed it without telling anyone.