My Cloud EX2 Ultra - Solid RED Light on Disc 1 (goes away on reboot)

I have a WD EX2 Ultra fitted with 2 Ironwolf Pro 8TB Drives. Originally it was set up for RAID 0 but then I got the red light on Drive 1. It did go off after a reboot but then came back a day or two later. I decided to switch to RAID 1 for safety and after doing so I RMA’d the hard drive back to Seagate. I fitted the replacement drive when it arrived and rebuilt the RAID (Yawn) and it worked fine for a week and then bingo - the red light came back on Drive 1. Again it goes away after a reboot.

Now I’m pretty sure the drive is OK and I think it must be a glitch with the WD’s firmware. Everything is backed up and it’s only media for personal use anyhow.

Scan Disk reports no issues and System Test is OK too. I have done the quick Disk Test which is also fine - will only do the full Test if I really have to as it takes forever. I had an external fan hooked up to one of the USBs which I’ve now plugged into an external USB adapter and I’ve also disabled drive sleep.

I’m beginning to think this may be a firmware issue.

UPDATE: I swapped the hard drives over just to see what would happen and surprise suprise the red light on HD1 came back after a couple of weeks - so that is THREE Seagate Iron Wolf Pro HDDs that the WD NAS is reporting as faulty, but only when fitted to bay #1. Something is not quite right!

1 Like

Hi @Hornets_Nest,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Thanks - yes I have raised a support case and sent them the file they asked for which has all of the SMART data on it.

At the moment the NAS has been running for three days with no red lights - I have disabled drive sleep and moved the external fan that I used for additional cooling to a USB power outlet not on the NAS itself.

I have read that WD NAS enclosures can be a little picky when it comes to HDDs.


Hi all,
I encountered the same behaviour with my device (same My Cloud EX2 Ultra, bought 2y ago, pre-populated with two disks of 4TB each), that started just some week ago.

@Hornets_Nest , do the sleep disabling and offloading of the cooling worked for your case?

Thanks in advance!

So far it’s behaved itself for a few weeks now.

Just returned from a holiday and started up the not so trusty WD Ex2 Ultra - within a couple of days I’m back to a red light on HD1 which goes after a re-boot.

It happened twice and I’ve just swapped the mirrored drives over just to see what happens.

Pretty sure Synology will be seeing some of my money soon as this NAS just doesn’t appear to be fit for purpose.

in the meanwhile i’m also trying what you’ve done for your NAS (cooling and no sleep) and at the time being, it is behaving with no issues :crossed_fingers:
When the red ligth was triggered on my nas, i remembered that there was also an error in the dashboard: it should be like ‘0003 “Drive SMART Failure”’, did you noticed if there is some similiar error?

I didn’t get any errors at all when my red light came on.

It’s come on twice since I’ve returned from holiday. My Seagate Drives are both Ironwolf Pros with the same model number but they are labelled differently & I belive they were manufactured in different countries. The HDD I RMA’d back to Seagate did run a few degrees hotter than the unit they sent back and they are both now within a degree of each other at 36 and 37 Celsius as I type. I have swapped them over just to see if that helps and so far no red light - it’s been nearly a week now.

To be honest I’m just playing around now and will change for a Synology when I have the time and the strength to transfer my data. I’ll probably run the WD with one HDD whilst I migrate my data to a Synology and once everything is working shut it down.

OK - it’s behaved itself for a few weeks - allthough I was away on holiday for most of the time.

Now the Red Light on HD1 AGAIN!

Being as I RMA’d one drive to Seagate AND swapped the HDDs around that means that THREE iron Wolf Pro Drives have issues according to my NAS ??? - this really ■■■■■, in fact WD really ■■■■.

Not sure if it has anything to do with my red light issue but the WD has behaved itself since the fimware update 5.27.157 - that is probably the kiss of death :joy: