Raid Health Degraded

I have a WD EX4 configured with three Red 3 TB drives and 1 Red 2 TB drive. The power led is flashing red and the display reads Vol 1. Degraded see dashboard. 

The NAS is configured with one RAID 5 volume and when I open the dashboard it goes to the RAID Profile screen which says that RAID Health is degraded. I did a manual rebuild and it still reports the volume as degraded and the Disk Status, all four drives report GOOD. I took a look at the S.M.A.R.T status, but I’m not certain what it is telling me. I need to do some more research, Essentially what I am trying to understand is which disk is going bad (I am assuming that some disk error is the root cause). 

I’m a little surprised by this as this NAS and the drives are under a year old and they don’t get that much use. It is used to backup a couple of MACs and a couple of PCs. I also have one additional question. If i determine which disk is going bad, can I simply swap out the bad disk for a new disk? I assume that I can, but can I replace the bad disk with one with more storage capability? If the 2 TB drive is the one going bad, I probably would like to replace it with another 3 TB or 4 TB drive. Somewhere when I first encountered this issue, I ran across a post saying something to the effect that the drive had to be the same size.

Thanks for any help/advice,



I would recommend to connect the drives directly to a computer using the SATA port or USB to SATA connection and running the Data Lifeguard tools to determinate if one of the drives is damaged. We recommend using the same size disks for RAID environment to assure RAID stability.

1 Like

My issue was almost identical, other than I have 4 x 4TB WDC drives.

I ran all tests and everything reported OK, green, etc.

The “solution” appeared to be to unselect on the Settings menu, under “Cloud Access” the “Cloud Service” box (that is, cloud services OFF).

I re-ran all the tests and everything is OK, green, etc.

I am VERY disappointed with WDC’s implementation of the WDMyCloud software and support. Settings “magically” change without my input. I had unselected this checkbox when I set up my NAS. Somehow it was selected again along with other settings.

I have also seen topics that recommend NOT updating the firmware for many reasons. (Just do a search, etc.)