RAID 5 Stuck in Wait to Resize


I had a EX4100 with 3x 6 TB in RAID5. I added 4th 6TB and used expand volume. When I monitor RAID parity check has completed and it says 100% expanded but for last 2 days after RAID parity check, its stuck in wait to resize status.

When will it show new free space. Any idea why its stuck in wait to resize status.

Filesystem Size Used Available Use% Mounted on
/dev/mapper/md1 10.8T 10.6T 71.4G 99% /mnt/HD/HD_a2


Hello Hari_Babu,

Please refer to the below community post about RAID rebuild taking days/weeks/months/not working?

Hi Logan,

Thanks for the reply. Issue is not with RAID re-balancing. Rebalancing completed in less than 36 hours for me. But WD is not showing me the free space in the volume. In the dashboard RAID page, it says wait to resize and stuck in that status for last 3 days. I even tried disconnecting from network for few hours thinking some external excess to the volume might be blocking it to resize, but still the same

df /mnt/HD/HD_a2

Filesystem 1K-blocks Used Available Use% Mounted on
/dev/mapper/md1 11620265376 10532439788 970682868 92% /mnt/HD/HD_a2

cat /proc/mdstat

Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md1 : active raid5 sdc2[3] sdd2[0] sda2[2] sdb2[1]
17568979392 blocks super 1.0 level 5, 64k chunk, algorithm 2 [4/4] [UUUU]
bitmap: 0/2 pages [0KB], 262144KB chunk

md0 : active raid1 sdc1[3] sda1[2] sdb1[1] sdd1[0]
2097088 blocks [4/4] [UUUU]
bitmap: 0/16 pages [0KB], 8KB chunk


This is the same issue I had when trying to go from a 2 x 3TB RAID1 to a 4 x 3TB RAID 5 on the fly. The disks were add into the RAID group, but then it would not change the personality of the RAID properly and resize the contents. I started to look in some of the scripts that WD use in the background to do the resizing and think there is a bug in the scripting somewhere and it was called with incorrect parameters so would not complete. To make matters worse I also went in the GUI and tried to select the option in there to increase the RAID size and from then on, got constant prompts about removing and reinserting Disk 1 which made absolutely no difference.

Only way I found to resolve it was to back everything up to another NAS and remove the original RAID, recreate it from scratch the way I wanted and then restore everything back over.



Thanks JediNite. I opened case with WD support and the only reply I got is, it will take 5 to 6 days. I lost my patience. Finally I did exactly what you said. I backed up everything and completely rebuilt from scratch. I had to gather all my old hd to backup 11 TB data. Luckily I had enough drives to backup. I have WD passport, my book, my cloud and ex4100. I was planning on buying pr4100 since ex4100 is getting full. After this issue looks like I have to start looking for options