DL4100 Expand RAID 5 volume stuck on Resizing

I have DL4100 with three 10 TB red drives configured in RAID 5 volume sized 19.1 TB. It was 95% full so I wanted to add a fourth 10 TB drive and expand the RAID volume onto the new drive which should result in a volume size of approximately 29.1 TB… I added the drive, went to Storage / RAID / Change RAID Mode / Expand Capacity, selected new drive, and the status changed to “Expanding Volume” with a steadily increasing % complete. After 5 days, the status was 100% and then changed to status “Resizing”. The size of the drive remained 19.1TB. 60 days later the status is still “Resizing” and size still 19.1TB. When I SSH to the system, TOP command shows process “resize2fs -fp /dev/md1 28600297M” consuming 50% CPU. “df -h” command shows size still 18.1TB for /dev/md1. “mdadm --detail /dev/md1” command shows Array Size 29286720960 and Used Dev Size 19524480640.

I opened two tickets with WD support and sent them logs. They claim logs show expansion complete and I should restart the system. When I tried to restart the system I was stopped by message “System shutdown…prohibited when the following operations are in progress: … disk formatting, disk resizing…”. WD support then told me to pull the power cord. I did, and when system restarted the status still shows “Resizing”, the size still shows 19.1TB, the resize2fs process is again running at 50% CPU, and I see same output from df and mdadm commands. I tried to kill the resize2fs process and it restarts automatically. After 60 days, WD support has no recommendation how to resolve this problem.

Does anyone know what I need to do to complete the resizing process?


Please refer to the following KBA article: My Cloud: RAID Online User Guide and Solutions

No help in any of those documents, nor from the three incident support tickets I opened. I followed the documented processes and have tried all the documented troubleshooting and repair procedures and all the instructions from technical support tickets without success. I am still stuck in “resizing” status with resize2fs running. On this first DL4100, I am giving up and will be reformatting and redefining the RAID 5 volume, losing my data, and then restoring 30 TB of data from backup. I have one more identical DL4100 and will be trying once again the same documented procedures. If there is a flaw in the DL4100 firmware or this version of resize2fs for 4x10 TB drives, I wish someone would be honest and tell me, and save me the time and frustration of several weeks of attempting the expanding process again on my second DL4100.