Problems with WD MyCloud EX2 Ultra under macOS High Sierra

Hi,
I’ve just recently purchased a WD MyCloud EX2 Ultra 8TB and I’m trying to set up for use from both MacBook Pro and Windows laptop. So far on Windows 10 laptop things seem to run smooth (WD Access works, access to files content upload/download works, …), whereas on mac side only partially. :slight_smile:

What my issues are:
Using MacBookPro 2014 running 10.13 (macOS High Sierra). No other NAS in use, no folder from MacBook being shared. Connection to network/NAS by WiFi.

  • WD Access does not find/recognize the WD MyCloud EX2 Ultra, even though it is visible in finder
  • When connecting to shared volumes in WD MyCloud EX2 Ultra (SMB), it seem to work but then I get permission error for any subfolder in any of the volumes. Access to each volume root folder works.
  • I need to manually connect in Finder to WD MyCloud EX2 Ultra every time I boot the MacBook

What is currently working in this mac setup, just in case it helps pointing to potential causes:

  • I’m able to access Control Panel web interface from Safari and adjust settings
  • I’ve been able to make a TimeMachine backup to the corresponding volume in WD MyCloud EX2 Ultra
  • I’ve been able to copy files (and its corresponding subfolder structure) from Finder once I’m connected to WD MyCloud EX2 Ultra with “Connect to server”
  • WD MyCloud EX2 Ultra shows up in Finder side bar under “Shared”

Any hint or help would be very welcome.
Best regards

Hi LPB,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support


The link below will allow you to call support if you are having trouble with the form.

I experience the same issues with my new ex2ultra… Even got it working with Vista just! But WD ACCESS/SYNC, I can only guess are not compatible with ~High Sierra?

Hi, Has this issue been solved by WD engineering? I have OS X High Sierra, and am considering purchasing WD Mycloud EX2 Ultra.
Thanks ahead for any updates!