Problem with Media Player

I have been happily using my Media Player for approx 4+ years now without a hitch until two days ago.

Set up:

  • I have several external drives that all work fine, that range from SS 8G cards to 500G WD HDD, and all have been virus/malware scanned via Norton.

- I have previously used all media types successfully on my Media Player - avi, mp3, etc.

  • I link my Media Player to my Denon A/V amp via HDMI, HDMI from amp to TV.

  • I have not updated the firmware (ever) as I have never needed to (it worked perfectly well for my needs)


Two days ago I was watching a couple different movies in sequence when the Media Player couldn’t load the next .avi file - when I started the file it froze on the opening frame. After it froze on the opening frame, I could still navigate back to the WD menu via the Back button. Furthermore, I could still navigate the WD menu (and my external drive) after this without problem.

This is when I checked all my external drives for problems, checked that it was not the source file etc. - there appears to be no problem from any of my drives nor the media files themselves.

I have since tried several different external drives on the Media Player, using files I know previously worked, using either of the USB ports, and using different file types (.avi, .mov, .wav, mp3 etc.) and the same problem occurs irrespective - the Media Player recognises the external source, I can navigate through the files, but when I press Play/Enter it either goes to a black screen for movies with no audio (just appears to black screen freeze, Note: compared to the first time it doesn’t freeze on the opening frame, just a black screen), or with music files it just freezes on the circular loading symbol. In both scenarios I can return back to the navigation menu without a problem using the Back button and navigate the source drive.

Interestingly enough, when I attempt to load a music file and the circular loading symbol appears, there is a ‘box/window’ around the circular loading symbol that is the same width and height as the circle. In this box I can see the frozen opening image of the first frame of the movie I was wanting to watch when this problem first occurred.

I found the following thread which seems to indicate that someone else had this problem in the past, but it wasn’t finalised:

Any ideas would be great. I didn’t realise how much I used the bloody thing until it didn’t work!



It sounds like the Matroska Header Compression issue, or something akin to it.

If you unplug the WDTV for an extended time and/or press the paperclip reset button and/or reset to factory defaults (and possibly also delete the .wdtv hidden folder) the player should get “unstuck” and back to playing all the files it once did… until it gets confused by another file.

Thanks mate, will give those suggestions a systematic try and see which/if any work and report any success/failure.

I forgot to mention before that I had turned on/off the unit numerous times, and left it ‘off’ overnight too, without any change. And I don’t use .mvk files - it froze on an .avi file TV episode.

It depends on how “stuck” it is… sometimes just the paperclip reset and/or the “Reset to factury defaults” is enough.

Once after playing a “bad” MKV file, my Gen1 was stuck and nothing was “fixing” it… even leaving it unplugged for an hour… I finally just unplugged it for 24 hours and that got it going again.  With my luck, one hour and 4 seconds would have been long enough. :wink: :smileyvery-happy:

lols True… that always seems to be the way :slight_smile:

I have unplugged the thing and will leave it an hour (perhaps an hour and 4 minutes… :wink: ), then turn it back on. If that doesn’t work I will then use the paperclip. If that doesn’t work I will then look at resetting the factory default/deleting the WD files etc.

OK, I left the device unplugged for longer than 1 hour 4 min as I had to go out with SWMBO. It was unplugged from the wall (c.f. just turning it ‘off’ by the remote) for approx 5 hours.

I just plugged it back in and it works fine - completely unfrozen and working again with the mp3’s and .avi’s that I have attached atm. The exact same external didn’t work before the Media Player being unplugged as recommended.

Thanks for the advice mate - perfect. :slight_smile: