Not able to play videos

Hi!

I’ve always been able to watch movies on my WD TV player (WD00AVP-00) but today I was not. I’m able to use the dashboard, see pictures but not movies. when I load the movie the screen is blank. I already upgraded to latest firmware and problem persists. I already tried using another external disc and problem persists. I also reset to factory settings and i was able to watch one movie, but when I stoped and went to another movie the problem came back again.

the videos that I am trying to play are the same that always played. Not different.

please help.

Thanks,

Tiago

I am having EXACTLY the same problem (which is why I am here).  I’ve tried changing firmware, using HDMI and composite and a multitude of different video formats.  Interestingly the unit will not playback Mp3s either.  It’s fine with graphics.

I was happily watching it over the Christmas period, and last night sat down to watch a movie and…NOTHING.

I’d love to know why.

Many thanks for any help you can offer us.

Stuart.

Hey Tiago!

I just found this and it fixed my problems!

http://wdtvhd.com/index.php?s=7ef9a1f34dddb5612bb8c33e202f1073&showtopic=19673&view=findpost&p=32066

The solution was:

Unplug all drives.

Plug into PC

Delete .wdtv folder from the root directory

Run chkdsk on drive to correct any issues (one drive out of 3 had problems).

Repeat for each drive.

Mine is now working perfectly again.

Cheers!

Can someone please explain how i can fix my wd media player live.

Im having troubles following these instructions.

Unplug all drives (from media player ??)

Plug into pc (via network lead or how do i do this?)

Can someone please help me?

My wd live media player takes ages to load videos after updating the firmware.

Cheers

I personaly am not having this issue but from my ubderstanding here is what he means:

1.Unplug all drives.(Remove any drives connected to WD Player)

2.Plug the drive that you disconnected from the player and plug them into your PC

  1. Explore (search) drives and find the folder named .wdtv and delete it, (there is only one in each drive that you disconnected from WD player and Delete the .wdtv folder)

4.Run chkdsk on each drive to correct any issues . If you don’t know how to do that  here is some good information on how to do it if your using WinXP

http://support.microsoft.com/kb/315265

Repeat steps 2 to 4 for each additional drives.

This is pretty straight forward…take your time step by step and you won’t have any problems.

Hope this helps you out :slight_smile:

Hey muzicmax,

Cheers for your post, but if you read a few posts back, you’ll see I posted the same solution :slight_smile:

Stu

Hey shanefromoz,

I take it you’ve already fixed this problem.  It’s pretty easy to figure out.  

  1. Yes, unplug them from the media player (they wouldn’t be plugged into anywhere else giving your media player problems!).

  2. You can’t run chkdsk on a networked drive, so it’d be via USB.

Dunno about the firmware issue.  I don’t use WD firmware.  If there’s an issue with it, downgrade and try again.

Cheers,

Stuart.

Hi everyone,

I have the same problem.

I have a WD TV HD Media Player (WD00AVP-00) and a WD 1TB Hard Drive.I have the firmware version 1.03.01 which I think is the latest. I checked, but couldn’t find anything newer.

The system was working fine until just last night. Now it won’t play any video files, .mkv or .avi. I tried following the advice listed above, but it hasn’t helped.

I’ve emailed the support people at WD and am waiting for a response.

Any ideas?

Thanks in advance!

Just thought I should add some more info…

I tried resetting to factory settings through the menus, and I tried resetting it with a paper clip to the button on the side. I also tried pulling out all the cables and let it sit for nearly an hour, but it didn’t help.

Cheers.

Sure sounds like the .mkv header compression issue.

You’ll have to reset the device, as covered in the FAQ, and then either delete any .mkv files that have compression in the headers, or re-mux them with compression turned off.

Hi, 

Sorry to ask the newbie questions… I’ve read the FAQ but there are just some things that I don’t understand. 

Ok, so firstly, I get that WD has left us on our own with this problem. They have said that they will no longer be issuing updates for the Gen 1 which is what we need to get this problem fixed. 

I checked up on WDLXTV but their web site says they can’t fix that problem either. 

Which leaves me with the cumbersome choice of finding which file is the problem. How do I do this? How do I work out which file is the problem file? 

After I’ve done this, I need to fix it using MKVMerge, which seems to a function of something called MKVToolNIX. Is this correct? So I need to download MKVToolNIX. 

What happens next? Do I need to reflash the Firmware or will the WDTVHD just work? 

Cheers!

Yes, you will need to have MKVToolnix installed on your computer.  If you knew which files were the problem, you could just use the GUI included in the package and re-multiplex the file(s) with compression turned off.

But, if you want, along with Toolnix (which it requires), you can download and install MKVFix.

If you run MKVFix, you can have it scan your files, looking for any that need re-muxing, and it will automatically fix them for you.

Once all your files are “fixed”, you will probably want to do the “Mega-Reset” on your WDTV:

  • Leave it unplugged for at least 10 minutes

  • When you plug it back in, _ RESET _ the unit by pressing the small button on the side, next to the USB #1 socket.  A paperclip is good for this. :wink:

  • Go to Settings and select Restore Factory Settings.  After this, you’ll have to re-establish your desired configuration items.

  • Delete the .wd-tv folder in the root of your USB device.

After that you should be fine to watch all your files, until you try to watch another file with compressed headers, then the box will lock up again, and again need to be reset.

If it’s both MKV and AVI giving you grief, then it’s not going to have anything to do with remuxing your MKVs.

Here’s a test for you.  

If you have a memory stick,

  1. Format the memory key in Windows (or your OS).  Format it as FAT32 if possible.

  2. Copy a small movie onto it.  Make it something like a DivX/XViD.  

  3. Make sure you safely remove the memory key!!!

  4. Unplug all your other USB devices from the media player, and just plug in this memory stick.

  5. Turn on the media player and let it scan for new files.  

  6. Once its finished, navigate to the memory stick, and execute the file off it.

At this point, I’m expecting you have a working video file?

If so, then the issue relates back to your storage drive again.  Now it’s unplugged from your media player, take it back to your computer and plug it in.  

Open My Computer (or Windows Explorer).

Locate the drive letter

Right click on the drive letter and select ‘Tools’

Click ‘Check Disk for Errors’ (or whatever its called)

Let Windows fix any errors it finds (let us know if it does find errors)

Eject the drive safely and return it to the media player and try again.

Let us know if you still have problems.

Cheers,

Stuart.

Stooj wrote:

If it’s both MKV and AVI giving you grief, then it’s not going to have anything to do with remuxing your MKVs.

 

No, that’s not true.

If the player gets borked by trying to play a compressed-header .mkv file, then it won’t play _ ANYTHING _ after that without a Mega-reset.  The player software gets all confused, and even turning it off and on doesn’t fix things – nothing will end up playing without a reset.

That’s always been the complaint with header-compression in the video stream – doesn’t matter whether on a Gen1, a Gen2, a Live or a Live Plus – after trying to play a .mkv file with compressed headers in the video stream, then nothing will play – even files that used to work before the “offending” .mkv was played.  When the compression was only in the audio stream, it used to “break” Gen1’s for all files, but Lives and Live Pluses would still play the video – there’d just be no audio.

@ RoofingGuy Maaaaate!

I did everything you said, exactly as you said it. Worked brilliantly. Love that MKVFix. Easy for Newbies like me to use. 

Thanks so much!

You’re welcome. :smiley:

I’m having a similar problem - my WD TV HD media player suddenly cannot play any of the video files that it had no problem with a week ago.

I’m trying to use the fix described above by RoofingGuy (mkvtoolnix and fix) - however i’m not sure i have the right installations

but when i tried to run the mkvfix program, it tells me the MKVToolnix is not installed.

Can someone tell me what i’m doing wrong - i use windows 7.

I’m assuming that’s an issue with the way MKVFix was originally written last fall.  When the guy wrote it, the “newest” toolnix was 4.3.0.

Try downloading 4.3.0 from: Windows versions and then see if MKVFix will run properly for you.

It shouldn’t be a Win7 issue, because I’m running Win7 as well.

Thanks for the help, I’ve downloaded the 4.3 version and fix ran fine, but on scanning the seperate hard drive i use to store media there were 0 files that needed remuxing.

Should i be scanning anything other than this hard drive?