Media Player not working correctly


I bought my player about 2.5 yrs ago. I’ve had no issues with it until this weekend. I use a USB key to plug into the MP to watch movies on my TV. Saturday afternoon, after I was done watching the last file on there, I removed the USB to go delete what was on it and put new movies on it - something I’ve done since I got it. When I put the USB back into the MP and pressed Play, nothing happened. Just a black screen. I tried all the other files and still nada. I played around with the settings, thinking I may have changed some by mistake. I then accidentally clicked down to PAL and when I went to scroll back up to NTSC, the MP  started freaking out. I don’t even know how to explain it. All I have are lines running up and down on my TV screen. I unplugged it for a while and plugged it back in, stll the same.  Today I thought it might be the USB that it suddenly did noty like so I plugged in an external hard drive, still the same. I read through a few pages of this forum, but did not see anything like what is happening to me.  Any advice would be appreciated. Thank you.


Try to reset the player, please see the link below:

1 Like

That worked! THANK YOU!

Hi There,

I purchased my WD media player Gen 1 last year Feb 2010 and updated it with Ver 1.03 web update and it worked ok conneceted it to WD passport to replace my 16gb pen drive. It was working fine since then without a problem until day before.

The first file played fine but the second one did not open. I thought it was incompatible format so I tried to play some other file that I had played before but even that did’nt work nor did the mp3s play. Since then I tried settings reset, deleted the .wdtv folder from pen drive and passport, firmware reset from the above post but still the same problem persists. It only plays one file for one time boot and black screen display shows up for the second or the loading circle for mp3s.

Whats wrong with my player which worked so well for more than a year?

Please help!!!

Once you play an unsupported file, it’s possible that NOTHING will play until you fully power it off and then back on.

You’ll need to fix your unsupported files, which most likely are suffering from MKV Header Removal Compression.

Search for that and you’ll find plenty of info on how to fix it.

1 Like

Thanks identified the file and solved the header compression issue now its working fine!!!