Weird problem with my WD media player.. it just stopped playing videos?

I hope someone here can help me with this. 

I turned on my player and plugged a hard drive usb into it. I started playing some random HD .mp4 files and they played just fine like usual. I then stopped the video to go play a different kind of file and it shows just a black screen. I hit the back button on the remote and it takes me back to the folder menu. I then tried playing another file, and the same thing happened. I then tried playing other files that it’s played perfectly fine and the same thing! I then tried plugging in a different hard drive and still just shows a black screen when I attempt to play a file. 

The .mp4 files I played just minutes ago were kind of unique files, very large… I even had problems burning them to DVD. I don’t know if maybe playing the file caused a setting to change or something? Is there a way I can like re-set it? I unplugged, re-plugged and all then and nothing. I’m just not sure, but it was playing videos just fine not too long ago, and now I can’t play a thing and i’m really upset.

If anyone can help i’d really appreciate it. I’ve only had this for like 6 months or so

I have had things like that happen. Some file, possibly corrupt or with some obscure setting in makemkv or ripbot etc or some inherent bug in the firmware, causing some hiccup, then causing the WD to half crash, so that one can select known good files files and they will play either audio and no video or just sit there.  I my case a power plug pull for a minute fixed it.

I would try a power plug pull for a minute and then try a known good file. if that fixes it I would consider that a file with some minor problem may cause a partial crash

Sometimes when you try to play a file that the WDTV doesn’t understand (such as .mkv files with compression in the headers on older firmwares, and, apparently, encrypted .ts files) the box gets confused and subsequently refuses to play anything, even files that used to play just fine.

Resetting the device will usually get it back working, until you play another “bad” file.

Sometimes, just unplugging the WDTV is sufficient to reset it, or pressing the paperclip reset button.

Occasionally, you need a more intense reset, such as:

  • unplug the power for at least 10 minutes
  • when you power it back on, press the paperclip reset button on the side
  • when it boots back up after the reset, select “Restore To Factory Defaults”

Thank you standard2! I will try that… but… how would I go about doing a power plug pull? If it means unplugged the power cord from the actual media player, I just tried that and it’s doing the same thing.


Roofing guy… thanks to you too! I will also try that. Where exactly in the setting can I find the “restore to factory settings” option??

I believe it’s in “Settings” – “System”.

But it’s somewhat of a “last resort” if unplugging and the reset button haven’t helped, since you’ll lose your all your settings (including Internet, sharing, and all your preferences you’ve changed in the Settings).

You might want to see if playback on “good files” is restored after the paperclip reset, before doing the “Reset To Factory Defaults”. :wink: