Had an issue and discovered the fix so I thought I would post it since I could not find the solution anywhere on the WWW and others maybe having the same issue.

The issue: Could not access the media files on the My Cloud EX Ultra HD (OS 5) via the WD TV Live Streaming Player’s network share feature. The Player wanted the HD’s username and password, but rejected everything tried.

The fix: Must change the SMB Protocol under Settings/Windows Services to SMB 1. I changed it to SMB 1, SMB 2, SBM 3. The default was SMB 2, SMB 3. No HD username or password needed. Just used the Player’s default username of “anonymous” and no password.

Problem fixed.