PR4100, Unable to set admin password

Hi Folks

I have a PR4100 that is misbehaving - I am unable to set an admin password, even after a full factory reset.

I can create an admin password when doing the initial setup but logging in afterwards says there’s no password.

I can create one after the initial setup but it immediately sets the slider to off Password Slider.

I’ve done a quick reset and a full reset and nothing helps - any thoughts would be very gratefully received. There’s no data on the device so happy to do whatever might help.

Many thanks in advance


@FCRC does your screen look like this?



Thanks for the thoughts.

I’ve done the 40 second reset with the paperclip and also the full factory reset from the GUI - same result.



I can’t keep the slider in the on position - it’s off, I choose to set a password (which I do without error) and then the slider automatically goes back to off and says no password is set…



never seen of that before, but the My Cloud uses REST API and Apache Web Server so you may need to do a Full Factory Restore and not just a System Only Restore.

Hi again

Having had no joy with the 40 second restore last week I did a full factory restore from the GUI - it took 12+ hours to complete.

I’ve just tried setting the password again and have the same result - however, if I try a simple password it will take it.

I’ve therefore done some playing and found it won’t take a left open bracket ( in the password - the same password without the ( works perfectly - really weird as you can enter a ( in the password field without complaint

Thanks for your help everyone


I am having the same issue, however I not using a left open bracket, seems to me that there are probably a number of non alphanumeric characters that are not compatible. simple passwords seem to work OK. Not exactly a paragon of safety what with all the ransomware threats about. Come on WD get this thing sorted! We bought the NAS for proper data protection.