Admin access to Dashboard after firmware update

I have a dl4100 and have never established an admin password and all folders are public. It was been working great for a year and now, coincident with a firmware update I can’t access the dashboard. The user is admin and in the password field it says no password created in gray letters. In the past I just hit the login button and the dashboard came up. Now it tells me “The user name or password you entered is incorrect. Visit here for assistance.”

I reset the NAS to factory defaults with the button on the back. I power cycled the device. I restarted it. Still the same problem.

I have to assume that it must be something in the firmware update. Is anyone out there having the same problem? Very frustrating.

Try http://www.mycloud.com/setup for the new onboarding process. Or do a system-reset-to-default by holding the reset button during bootup for at least 30 seconds, then the system is back to be onboarded again.

Withtin My Cloud OS 3, now the user has to setup a password for the admin account. This was introduced due to tons of claims about unsecurity having a NAS without the obligation to set an admin password.

1 Like

Do what? mycloud.com/setup ???
Are you saying you can’t use this as a NAS ? Just a place to store a bunch of stuff on the local LAN?

Of course you can - that’s there main purpose! With My Cloud OS 3, there are two ways to onboard the unit, the one using the classic web interface of the device, the other one using a browser based onboarding process. Depends on what the user want to use.

Jörg what happens with the data on the hard drives then? Everything get erase, doesn’t it?

mycluod.comm/setup can’t find my nas. It is operating normally, I can see it and the files in it using file explorer. I’ve tried the reset button but not for 30 sec. I thought that would wipe the drives. Any other thoughts.

I spent 2 hours with WD tech support and I wanted to Share the resolution of my problem with the community. It took level 2 and some trial and error to find a way to reset my NAS but we finally got it done. The process is not the documented one.

  1. power down the NAS
    2)unplug power and network connections
  2. with a paperclip or similar push the rest button on the back of the NAS, While holding it in plug in the power and then the network. hold in the reset button for 45 seconds.
  3. the NAS will boot uo and then reboot.

This process reset my NAS and access was returned to the prior state.

In my conversations with Tech support, I found out two facts that are contrary to some speculation on this thread. First, the firmware update does not change the password requirement. You still don’t need to set an admin password. And secondly, a reset to factory defaults will not effect your data. Data can only be erased by admin through the dashboard.

2 Likes

No, no data will be erased if you do a System-Reset-to-Default. Data will be erased only if you do a FULL Restore but this Full Restore must be triggered from within the web interface. It cannot be triggered by pressing the Reset button at the backside of the chassis.

2 Likes

if you are using the onboarding process on mycloud.com/setup, then you have to set a password with at least 8 digits length containing uppercase and lowercase alphanumeric letters and one number or special character.

If you onboard by using the web interface, then you don’t need to set a password, you can simply skip this; but this is not recommended and this was critisied by many people in the past.

So, during this process from step 2 upwards, you didn’t press the power button to start the NAS?

This is how I’ve interpreted that you’ve written. Please let us know if my interpretation is correct or incorrect.

  1. Power down the NAS buy using the power button.
  2. Unplug the power cord and network cable.
  3. With a paper-clip or similar push the reset button on the back of the NAS,
  4. While holding it in plug in the power and then the network while holding in the reset button for 45 seconds.
  5. When the reset button is released the the NAS will start and then reboot.

Your write-up is open to different interpretations. What was the exact procedure for the NAS recovery?

You’re right I left out an important detail—
3) with a paperclip or similar push the rest button on the back of the NAS, While holding it in plug in the power and then the network and depress the power button on the front . hold in the reset button for 45 seconds.

I had tried the documented reset process several times and so did level 1 and 2 Tech Support. Every time we got the same result-no reset. This process was noticeable different. The NAS rebooted and the restarted again on its own.

1 Like

That’s of concern here is that L1 and L2 tech support didn’t exactly know how the reset procedure worked unless other things were tried before this.

What sort of reset was performed? Dis all the users on the NAS survive? I assume this performed a system only restore?

The problem I was working was inability to access the Dashboard. This process solved that problem by resetting my password. I can only assume that it was a system reset. I only had public shares. The documentation says that a system reset will make all private shares public. But the process got me back to where I was before my access problems, No data was affected by the process

1 Like

That 5th step is good to know as it confirms the system only reset is happening. This is where the NAS won’t start until the reset button is released and then when the NAS starts it automatically performs a re-boot.

This is correct? You’ve got a lot further that me in discovering the exact procedure. This should be in the user documentation with a clear description on what it does and what to expect.