Pls help - 4TB MyCloud won't recognise 4TB WD My Passport

I have just purchased a 4TB WD My Passport so that I could connect it to the USB port of my 4TB WD My Cloud (running firmware v04.05.00-342) and act as a backup for My Cloud. Despite being the same company the devices do not work together.

The MyCloud Desktop (v. nor the drive itself when opened via Finder, is able to recognise the My Passport regardless of how the device is formatted. I have tried both HFS+J and ExFat as offered by the WD Discovery software (v.3.9.234) on my Mac (running macOS High Sierra 10.13.6). I even tried formatting it via Disk Utility to a Mac OS Extended (Journaled) format but this also doesn’t work.

I haven’t added any extra security or anything like that - it’s just a plain formatted external hard drive. This is VERY annoying. Please help! Thank you.

The My Cloud Desktop application is no longer being supported by WD. That application has been End of Life since 2016.

The single bay My Cloud units generally only support; NTFS, HFS+ or FAT32 for external USB drive formats.

External USB Drive File Systems Supported on a My Cloud

The single bay My Cloud is somewhat temperamental when it comes to detecting certain USB hard drives. Some simply don’t work and are not recognized. In other cases one may have to ensure there is only one partition on the USB drive. If a USB drive uses hardware encryption, make sure it’s disabled.

Thanks but I got it going. There were 2 issues. Firstly I needed to use HFS+J format for it to be detected correctly. Secondly, the USB extension cable was not getting enough power to the external device so I plugged it in directly. Thanks for the help anyway