Plex Problems


#1

Okay Plex was working fine no problems. I uploaded a load of files off my laptop and the Plex server became unreachable.

I have,

  • Rebooted “My Cloud Home”
  • Rebooted Router
  • Shutdown and Restarted “My Cloud Home”

None of which worked.

I then

  • Disabled “Plex” under services
  • Rebooted “My Cloud Home”
  • Tried to Renable “Plex”

Now I’m struggling to get it to enable/restart.

Any ideas?


#2

How long did you wait after the upload? And is it just the Plex server that’s unreachable, or the whole device?

Uploading may trigger processes like cataloging and downloading of metadata and that sort of stuff, which can be very processor consuming. You might need to wait until it’s finished doing stuff before things become responsive again.

I’ve had similar experiences with other services on my WD NAS, due to the low power of their processors (as that kind of thing isn’t really what they’re designed for). To be honest I didn’t even try Plex for that reason - mine runs on a seperate Raspberry Pi3 instead and works fine there. Just leaving the NAS to sling files around…


#3

Still can’t enable Plex. Is there any way to reset Plex without deleting all the files?


#4

There I can’t help unfortunately. I tried it, saw how useless it was on the hardware (especially CPU) that the NAS offers and moved my home Plex server onto a Raspberry Pi instead where it has remained ever since.


#5

Still failing to connect to the Plex server despite several reboots & shutdowns.

Totally losing faith in this product… do a factory reset and copy all the files back on will take me days.

Utter garbage with ZERO support


#6

@gibbylinks Based on your description, there could be an issue with the Plex Index or DB.
Try these steps

  • Ensure that you have a copy of the content inside of the Plex Folder on another physical device
  • Disable Plex
  • Rename the Plex folder to PlexOld or something
  • Power OFF the MCH (not reboot)
  • Wait a few minutes
  • Power ON the MCH
  • Enable Plex and wait
  • Verify that a new Plex folder was created when Plex goes into Enabled Mode
  • Go through the Plex setup process

If all is OK, you’ll need to copy & paste or drag and drop the content into the new Plex Folders, but you may run into the same issue. In this case, Plex on MCH already has debugging enabled and sends the logs to Plex dev team (these logs do not come to WD)


#7

Thanks for your help, I’ll give this a go, although considering there is no facility to backup this device

Could be an issue? Luckily I have them on my old “My Cloud”. Regret not buying another of those instead.